How to know if metronome is working?

Discussion in 'Installation/Configuration' started by dioobr, Feb 16, 2017.

  1. dioobr

    dioobr New Member

    Hello,

    I have a multiserver configuration, and a dedicated server only the XMPP service (metronome), but I don't know if it's working. I tried setting up an XMPP account on Bria, but it didn't work, or I'm doing something wrong.

    In ISPConfig, I registered the domain test.example.com (DNS entry ok) with SSL support and then I created an account. Okay up here.

    I checked the metronome settings (/etc/metronome/global.cfg.lua) that the ports for HTTP and HTTPS are 5290 and 5291 respectively.

    When I access http://test.example.com:5290, it shows a page reporting error 404. The same to https://test.example.com:5291 (with the detail that the certificate created during the installation of ISPConfig is Called, not that of the domain in question).

    Here /etc/metronome/global.cfg.lua

    Code:
    pidfile = "/var/run/metronome/metronome.pid";
    metronome_max_files_soft = 200000;
    metronome_max_files_hard = 300000;
    plugin_paths = {
            "/usr/lib/metronome/isp-modules",
    };
    use_libevent = true;
    log = {
            debug = "/var/log/metronome/metronome.dbg",
            info = "/var/log/metronome/metronome.log",
            error = "/var/log/metronome/metronome.err",
    };
    use_ipv6 = false;
    http_ports = {
            5290,
    };
    https_ports = {
            5291,
    };
    pastebin_ports = {
            5292,
    };
    bosh_ports = {
            5280,
    };
    admins = {
        "[email protected]",
        "[email protected]",
    
    };
    modules_enabled = {
        "saslauth",
        "tls",
        "dialback",
        "disco",
        "discoitems",
        "version",
        "uptime",
        "time",
        "ping",
        "admin_adhoc",
        "admin_telnet",
        "bosh",
        "posix",
        "announce",
        "offline",
        "webpresence",
        "mam",
        "stream_management",
        "message_carbons",
    
    };
    modules_disabled = {
    };
    bosh_max_inactivity = 30;
    consider_bosh_secure = true;
    cross_domain_bosh = true;
    allow_registration = true;
    -- TODO generate ssl key during setup
    ssl = {
            key = "/etc/metronome/certs/localhost.key",
            certificate = "/etc/metronome/certs/localhost.cert",
    };
    c2s_require_encryption = false;
    s2s_secure = true;
    s2s_insecure_domains = {
            "gmail.com",
    };
    and here /etc/metronome/hosts/test.example.com.cfg.lua:

    Code:
    VirtualHost "test.example.com"
        enabled = true;
        authentication = "external";
        external_auth_command = "/usr/lib/metronome/isp-modules/mod_auth_external/authenticate_isp.sh";
        allow_registration = false;
                no_registration_whitelist = true;
    
            modules_enabled = {
                    "roster",
                    "private",
                    "vcard",
                    "privacy",
                    "pep",
                    "admin_adhoc",
            };
            disco_items = {
            };
    
            admins = {
            "[email protected]"
    
            };
            ssl = {
                    key = "/etc/metronome/certs/test.example.com.key",
                    certificate = "/etc/metronome/certs/text.example.com.cert",
            };
    
    Thanks!
     
  2. dioobr

    dioobr New Member

    Hello,
    Can someone help me? I've tried configuring it on Bria and Thunderbird, but it doesn't work. Where to start to make it work?
     
  3. niktel

    niktel New Member

    I have the same problem
     

Share This Page