How to install zabbix in web folder

Discussion in 'HOWTO-Related Questions' started by steve1084, Jul 13, 2007.

  1. steve1084

    steve1084 New Member

    Hi Falko

    I just tried doing the install of Zabbix on my debian etch with ispconfig and suphp only to find that it wont work because php is globaly turned off.

    I did find one thread that suggested installing into a web folder created by ispconfig.

    Thats where I fall down because in the install script It doesn't ask where you want to install it.

    apt-get install zabbix-server-mysql zabbix-frontend-php zabbix-agent

    What do I do. Do I run this command from within the chosen www folder. and also do I need to remove the none working current install.

    Is there an alternative install method just for inside webhost folder.

    Can the howto be updated to include relevent info for people running ispconfig or at least add a link to a forum thread for people using ispconfig

    Thanks
    Steve:)
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/zabbix/apache.conf?

    I think you must copy the contents into the Apache Directives field of a web site in ISPConfig. Afterwards, you should be able to access Zabbix in that web site.
     
  3. steve1084

    steve1084 New Member


    Hi Falko

    Contents are

    When I go to the zabbix folder 192.168.1.23/zabbix/
    Instead of getting a working zabbix I get the script contents as follows

    Thanks
    Steve:)
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Did you enable PHP for that web site? Can you post the vhost configuration here (from Vhosts_ispconfig.conf)?
     
  5. steve1084

    steve1084 New Member

    Yes I did

    Here is all I can give

    /etc/zabbix/apache.conf

    /etc/zabbix/dbconfig.php


    /etc/zabbix/zabbix_agentd.conf

    /etc/zabbix/zabbix_server.conf





    /etc/apache2/vhosts/Vhosts_ispconfig.conf


    I have edited to remove none relevant sites info



    Checked the xabbix log files and no errors reported

    If I try via the ip I get the php code as previously reported ie 192.168.1.100/zabbix
    If I try via the we address http://www.zabbix.my1084.com/zabbix/ I get 500 error - Internal Server Error!


    Thanks
    Steve:)
     
    Last edited: Jul 16, 2007
  6. falko

    falko Super Moderator ISPConfig Developer

    Can you try to switch off suPHP? Maybe that's the problem...

    Any errors in Apache's error log?
     
  7. steve1084

    steve1084 New Member

    Hi Falko

    Sorry about the delay

    Yes tried turning off suphp

    here are some of the log files

     
  8. falko

    falko Super Moderator ISPConfig Developer

    Are you absolutely sure you've switched off suPHP?
     

Share This Page