How to install VMWare Server 1.0 on Ubuntu 10?

Discussion in 'Installation/Configuration' started by jimerman, Apr 1, 2011.

  1. jimerman

    jimerman New Member

    I found this great post on installing on version 9.


    With a grain of salt I followed the procedure (substituting the newer versions of the source, kernel, etc.). However, the VMWare installation complained that I had to build vmmon for the kernel, and every time I tried it bombed out.

    First it complained about not finding asm/semaphore.h, so I found where it was, created an asm folder, and copied the contents (from the linux/ folder). Eventually I got down to this build error.

    Any ideas? I tried VMWare Server 2.0, but the problem I couldn't get around was that the web based admin console plugin is not compatible with Firefox 3.6, and I don't know how to downgrade / install Firefox to 3.5.

    My existing Windows box is running VMWare 1.0, and I like the admin interface much better (much faster and more stable). I am trying to replace the unstable Windows host with a Linux box.

    I run through the vmware install script, and when I build vmmon, this is the final error:

    Code:
    ...
    /tmp/vmware-config4/vmmon-only/./include/vm_basic_asm_x86.h:443: warning: "_MSC_VER" is not defined
    In file included from /tmp/vmware-config4/vmmon-only/common/vmciContext.c:30:
    /tmp/vmware-config4/vmmon-only/common/hostif.h:39: warning: "WINNT_DDK" is not defined
    make[2]: *** [/tmp/vmware-config4/vmmon-only/common/vmciContext.o] Error 1
    make[1]: *** [_module_/tmp/vmware-config4/vmmon-only] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.35.11-custom'
    make: *** [vmmon.ko] Error 2
    make: Leaving directory `/tmp/vmware-config4/vmmon-only'
    Unable to build the vmmon module.
    
    For more information on how to troubleshoot module-related problems, please 
    visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
    "http://www.vmware.com/support/reference/linux/prebuilt_modules_linux.html".
    
    Execution aborted.
    
    
     
    Last edited: Apr 1, 2011
  2. falko

    falko Super Moderator

Share This Page