How to install PHP 7.1, 7.2 and 5.6 as PHP-FPM & FastCGI for ISPConfig 3 on Centos 7

Discussion in 'ISPConfig 3 Priority Support' started by nmazza, Mar 8, 2018.

  1. nmazza

    nmazza Member

    Dear Support
    Hello, again
    How to install PHP 7.1, 7.2 and 5.6 as PHP-FPM & FastCGI for ISPConfig 3 on Centos 7
    During the last two months, I had lost a new and old clients, because they needed PHP 7.1 and PHP 5.6
    What is the best way to update or install a new SERVER Centos with PHP 5 and PHP 7
    Some new sites over CodeIgniter Web Framework, doesn't work over PHP Version 5.3.3 / PHP Version 5.4.16
    Thanks,
    Nestor Mazza
    I'll appreciate your cooperation.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    When you find some suitable RPM that do not replace the default PHP, then you might use them. Or you compile the other PHP versions from source, that should work in any case. As far as I know, there is no tutorial available on that topic on Howtoforge for CentOS and PHP 7, but you might find tutorials at other sites by using Google search.
     
  3. nmazza

    nmazza Member

    Hello,
    I had tested on one of my servers, but when I execute yum check-update after add remi as reporitory
    I had recived a lot of broken packages, and I decided abort the intallation.
    and aditionally I had teste over CentOS 6.9 too with the similar problems.
    I don't know to solve this situation.
    If you know a good link for me, about solve this, I appreciate your cooperation
    Thanks for all
    Nestor Mazza
     

Share This Page