How to install PHP 5.6.30 as PHP-FPM & FastCGI for ISPConfig 3.1 on Debian 9

Discussion in 'HOWTO-Related Questions' started by origrafica, Oct 9, 2017.

  1. origrafica

    origrafica New Member

    I need to install PHP 5.6.30 on a Debian 9 server where run PHP 7.
    I have to run some Joomla 2.5 and 1.5 sites.
    But I do not find any really functional guide!

    Thanks to who will want to give me a track to follow
     
  2. HSorgYves

    HSorgYves Active Member

    If you run Joomla! 2.5 or especially Joomla! 1.5 sites on your server you can write "Hack me!" on it. They are so unsecure that they - depending on the exact version - make your whole server at risk. You should upgrade them as soon as possible ot get rid of them!
     
  3. ztk.me

    ztk.me ISPConfig Developer ISPConfig Developer

  4. Fernanda Munhoz

    Fernanda Munhoz New Member

    Hey ztk,
    Thanks for sharing this guide. I had the same doubt here. I'll try to to and I'll post my results later!,
    Cheers,
    Fer
     
  5. yuvan

    yuvan New Member

    Hi,
    Follow the below points to install install PHP 5.6.30 as PHP-FPM & FastCGI for ISPConfig 3.1 on Debian 9 .
    1. Install PHP directly from Debian PHP Package maintainers site with apt-get.
    2. Enable PHP versions in ISPConfig:In ISPConfig 3, you can configure the new PHP versions under System > Additional PHP Versions.
    3. Change PHP version of websites
    4. Add the repository at packages.sury.org
    5. Install PHP from packages.sury.org
    6. Install Memcache extension (optional)
    7. Install APCu extension (optional)
    8. Install xDebug extension (optional)
    • Install xDebug extension (optional)
    • Restart FPM daemo
     

Share This Page