How to Install nginx and google PageSpeed on Ubuntu 16.04 problem in step 4

Discussion in 'HOWTO-Related Questions' started by mart28, Nov 25, 2016.

  1. mart28

    mart28 New Member

    Hi

    I'm following this tutorial
    I have a problem in step 4

    https://www.howtoforge.com/tutorial/how-to-install-nginx-and-google-pagespeed-on-ubuntu-16-04/



    I do


    sudo apt-get install dpkg-dev build-essential zlib1g-dev libpcre3 libpcre3-dev unzip
    7 nano /etc/apt/sources.list.d/nginx.list
    8 sudo sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys ABF5BD827BD9BF62
    9 sudo apt-get update
    10 cd ~
    11 mkdir -p ~/new/nginx_source/
    12 cd ~/new/nginx_source/
    13 apt-get source nginx
    14 sudo apt-get source nginx
    15 rm -rf /var/lib/apt/lists/
    16 apt-get update
    17 apt-get build-dep nginx
    18 ls -l
    19 mkdir -p ~/new/ngx_pagespeed/
    20 cd ~/new/ngx_pagespeed/
    21 ngx_version= 1.11.33.4 comand no found

    23 wget https://github.com/pagespeed/ngx_pagespeed/archive/release-1.11.33.4-beta.zip
    24 unzip release-1.11.33.4-beta.zip
    25 cd ngx_pagespeed-release-1.11.33.4-beta/
    26 wget https://dl.google.com/dl/page-speed/psol/1.11.33.4.tar.gz
    27 tar -xzvf 1.11.33.4.tar.gz
    28 cd ~/new/nginx_source/nginx-1.10.2/debian/
    29 nano rules



    Step 4 - Configure nginx to build with Pagespeed

    Add the new line under 'COMMON_CONFIGURE_ARGS':


    I do not have this line and it does not look like the photo

    [​IMG]

    PKGS = nginx nginx-dbg
    BUILDDIR_nginx = $(CURDIR)/debian/build-nginx
    BUILDDIR_nginx_debug = $(CURDIR)/debian/build-nginx-debug
    INSTALLDIR = $(CURDIR)/debian/nginx
    BASEDIR = $(CURDIR)
    ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
    NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
    ifeq (${NUMJOBS}, 0)
    NUMJOBS = 1
    endif
    else
    NUMJOBS = 1
    endif
    DO_PKGS = $(PKGS)
    config.env.%:
    dh_testdir
    mkdir -p $(BUILDDIR_$*)
    cp -Pa $(CURDIR)/auto $(BUILDDIR_$*)/
    cp -Pa $(CURDIR)/conf $(BUILDDIR_$*)/
    cp -Pa $(CURDIR)/configure $(BUILDDIR_$*)/
    cp -Pa $(CURDIR)/contrib $(BUILDDIR_$*)/
    cp -Pa $(CURDIR)/man $(BUILDDIR_$*)/
    cp -Pa $(CURDIR)/src $(BUILDDIR_$*)/
    touch $@

    .....

    What am I doing wrong?

    thanks
     

Share This Page