how to install GD extension with ispconfig additional php5.6-fpm

Discussion in 'Installation/Configuration' started by kmchen, Oct 14, 2018.

  1. kmchen

    kmchen Member

    Hi,
    I installed php5.6-fpm as additional extension in isconfig-3.1.13 for an old web site on a debian 9 server. I added old extensions mysql and gd that way:
    compiled and installed without problems. Mysql connection works fine after some adaptations and
    the GD extension seems to be fine:
    but the old web site still complains about GD library with that type of message:
    Any idea ?
     
  2. Ole Vangen

    Ole Vangen Member

    I have same problem. Anyone that has solved this?
    I have installed the gd library for php 5.6
    I tried first edit the general php file.
    Then I was thinking that php 5.6 is an adition and I edit the php.ini file in the folder /opt/php-5.6/lib I also edit the php.ini file that was in the webfolder of the site. and restarted apache but stil I cant see any GD library when I check the url of the site for php info.

    Any suggestions to how to make it work?
     
    Last edited: May 20, 2020
  3. Ole Vangen

    Ole Vangen Member

    Anyone that has had same problem and fixed it?
     
  4. ahrasis

    ahrasis Well-Known Member

    We mostly are using Ondrej Sury repo for php and that is including php5.6. That way we just need to use apt-get install php5.6-gd and this is the easiest yet safest way if compared to your self-compiled method.
     

Share This Page