How to install dokeos on an ISPConfig server

Discussion in 'Installation/Configuration' started by p.a, Nov 25, 2008.

  1. p.a

    p.a New Member


    I have an OpenSuse 11 with ISPConfig 2.2.27 on it.
    I created some websites and it worked well.
    Now I'd like to install dokeos 1.8.4 with ISPConfig.

    The first problem I met was with the mysql databases. Dokeos use 3 databases + additional databases for each course (after installation, dokeos is used to manage courses). I started to create a db and couldn't change it's name. Moreover when I create a second database I have another db user that is created. When I try to install dokeos I can only choose one db user to access the 3 databases (the user will also be used in the future to create courses and so additional databases).

    To solve this, I created manually a superuser within mysql to install dokeos. It must not be recommended but it works for the install.

    After that I could install dokeos. I tried to create a new course and it seems to be ok with the db (I can see it in MySQL) but I can't access the course.
    The courses are created in dokeos/courses in which I can find a .htaccess, a TEST directory (the course directory) and an index.html file. The files within dokeos/courses seem to have bad authorization : wwwrun:www where each other files in dokeos/ have web10_dokeos:web10.
    I tried to add web10_dokeos to www but it didn't solve anything.

    As you can see I have some issues : The first is that I have to perform "manual" operations. The second is that I have problem with dokeos.
    Another thing I met is that I had to change the php.ini file globally to install dokeos (maybe it's possible to change it on a per user basis but I don't know how).

    Does someone already installed dokeos on an ISPConfig server ? How to do it properly then ? Any advices ?

    Thanks in advance,

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Most likely the dekeos developesr will be able to help you better as this is more a dekeos issue then a ispconfig issue. ISPConfig uses a simple apache mod_php setup, there is nothing special with that.

    you can set this with php_admin_flag and php_admin_value lines in the apache directives field of the website.

Share This Page