How To Install Alfresco Community 3.3 On Ubuntu Server 10.04 - Start Problem

Discussion in 'HOWTO-Related Questions' started by snarf77, Sep 3, 2010.

  1. snarf77

    snarf77 New Member

    Hi all,

    This is my first post in this forum so hello to everyone.

    This is my problem:
    I got alfresco working on another machine one year ago (should be ubuntu 9.04 desktop) and now I'm trying to reinstall everything on a fresh install of ubuntu server 10.04 (x64).

    I found this excellent tuto on how to forge but i'm stuck at the end (9.3) for a permission problem.

    here is my terminal output:
    Permission non accordée = permission denied (in french)

    As I installed everything in root and all files seem to belong to root, I really dont understand the error. Does some of you already encounter this problem of know how to work around ?

    Thanks in advance

    Snarf
     
  2. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    ls -la /opt/alfresco/tomcat/bin/
    ?
     
  3. snarf77

    snarf77 New Member

    Thanks in advance for your help...

    here the terminal result:

    Code:
    administrator@GED:/opt/alfresco/tomcat/bin$ ls -la
    total 372
    drwxr-xr-x  2 root root   4096 2010-09-03 10:35 .
    drwxr-xr-x 11 root root   4096 2010-09-03 10:35 ..
    -rw-r--r--  1 root root  17519 2008-07-22 03:01 bootstrap.jar
    -rwxr-xr-x  1 root root  12907 2008-07-22 03:01 catalina.sh
    -rw-r--r--  1 root root   2374 2008-07-22 03:01 catalina-tasks.xml
    -rw-r--r--  1 root root   9341 2008-07-22 03:01 commons-daemon.jar
    -rwxr-xr-x  1 root root   1624 2008-07-22 03:01 digest.sh
    -rw-r--r--  1 root root  74398 2008-07-22 03:01 jsvc.tar.gz
    -rwxr-xr-x  1 root root   4447 2008-07-22 03:01 setclasspath.sh
    -rwxr-xr-x  1 root root   1563 2008-07-22 03:01 shutdown.sh
    -rwxr-xr-x  1 root root   1956 2008-07-22 03:01 startup.sh
    -rw-r--r--  1 root root  18984 2008-07-22 03:01 tomcat-juli.jar
    -rw-r--r--  1 root root 189757 2008-07-22 03:01 tomcat-native.tar.gz
    -rwxr-xr-x  1 root root   3291 2008-07-22 03:01 tool-wrapper.sh
    -rwxr-xr-x  1 root root   1567 2008-07-22 03:01 version.sh
    administrator@GED:/opt/alfresco/tomcat/bin$ 
    
    Do you see something abnormal ?

    I edit this post to add some details of my install as it could perhaps help anyone to get an idea:

    I wanted to install alfresco on a separate partition (lvm type). So I mount this partition in /media/GED.
    I then created an alfresco directory under /media/GED and I finally simlinked /opt/alfresco to point to this directory.
    That is the only thing which is not exactly as the "how to"
    I don't think this can come from this but it's always better to explain !!
     
    Last edited: Sep 4, 2010
  4. henzbelmont

    henzbelmont New Member

    Is it possible to install it on one computer then just copy the registry files and use it on another computer? T His might save us time but is this possible? I have been doing this on games. playpokiesonline
     
    Last edited: Sep 6, 2010
  5. falko

    falko Super Moderator ISPConfig Developer

    Permissions look ok. Did you disable AppArmor?
     
  6. snarf77

    snarf77 New Member

    Thank you all...

    falko,
    Apparmor was not disable... That's a good idea. I will try tomorrow without it.


    henzbelmont,
    What kind of registyry files are you talking about ? all the tomcat directory ?

    Bye
     
  7. snarf77

    snarf77 New Member

    Unfortunately same problem with apparmor disable...
     

Share This Page