How to import a big MySQL dumpfile

Discussion in 'General' started by Hans, Oct 5, 2007.

  1. Hans

    Hans Moderator ISPConfig Developer

    I am using the phpMyAdmin package for ISPConfig to import a MySQL dumpfile with the size of 36 MB.

    The maximum size of a MySQL that can be imported with phpMyAdmin by default is 8 MB, so i increased the value of post_max_size = 8M within the file /root/ispconfig/php/php.ini to a higher value then the size of the file to be imported.

    Although, i've increased the value of post_max_size, the maximum file i can import, is still not more then 10 MB.

    How is this possible and is there another way to import such a big MySQL dumpfile?
     
  2. the_spy

    the_spy New Member

    mysql -h host -u user -ppass database < sql_file
     
  3. Hans

    Hans Moderator ISPConfig Developer

    MySQL database imported successfully.

    Thanks for your reply.

    In the mean time i did:

    mysql -p -h localhost webX_dbX < filename.sql

    This worked fine. :)

    But i am still wondering why i can not import a bigger mySQL file then 10 MB using phpMyAdmin, because i changed the post_max_size = 8M within the file /root/ispconfig/php/php.ini to a higher value.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Take a look here: http://www.howtoforge.com/faq/6_4_en.html

    Do you use a browser like IE that timeouts after 30 seconds? That might be the problem...
     
  5. Hans

    Hans Moderator ISPConfig Developer

    No, i never use IE, but Opera. I think it has nothing to do with the browser. ALso after pressing the Import button within phpMyAdmin i see the maximum size displayed, which is only 10 MB.I think it has something to do with the content of the phpmyadmin configuration file. I will check that.
     
  6. the_spy

    the_spy New Member

    may be there is also an other option in php.ini , like file_upload or so, I don't remember exactly but I remember seeing some options about size limits
     

Share This Page