How To get working my scenario

Discussion in 'Installation/Configuration' started by miooodek, Aug 27, 2010.

  1. miooodek

    miooodek New Member

    Hi,

    I was trying to do it myself, but after reading few instructions I just can't get it work

    my scenario:

    actually I have no registered domain, but I'm trying to set up some non existing domain in my local area network.

    1. my domain name (in lan) will be "harakiri.pl"

    2. ip addres of host with mydnsconf: 192.168.13.149
    3. server name: pielgrzym.harakiri.pl

    4. ther's no other dns server in my lan

    my current (not working) configuration of DNS Zone

    [​IMG]

    and Records

    [​IMG]


    Thanks in advance for your time
     
  2. till

    till Super Moderator

    The zone is imcomplete and misses amlot of records and in the NS-record there are also the dots missing. The esaiest way to fix this is that you delete the whole zone and then recreate it by using the dns wizard.
     
  3. miooodek

    miooodek New Member

    OK, I have created sth like this by wizard, and it's still not working, but now, I'm using domain "erpi.pl"

    DNS Zone

    [​IMG]


    Records

    [​IMG]
     
    Last edited: Aug 28, 2010
  4. zenny

    zenny New Member

    What can't you make work?

    If you cannot access locally the domains, please follow the faq which states that you have to add the specific IP and the domain in your /etc/hosts file of the workstation that you are using.

    In your case, add the following line in the /etc/hosts file of your workstation:

    192.168.13.149 pielgryzym.erpi.pl

    Else read this: http://www.faqforge.com/linux/contr...ess-a-namebased-website-without-a-dns-record/

    Thanks to Till for elaborating this to me!! :)
     
  5. miooodek

    miooodek New Member

    I want dns working locally, but not a hosts file.
     
  6. till

    till Super Moderator

    Then reconfigure your workstation so that it uses the ispconfig server as dns server. The recordsa bove are ok for a local network.

    you can test the dns server locally by executing this command on the shell of the server:

    dig @localhost erpi.pl

    if it returns the local IP of the server that you set in the dns srecords, then it works.
     
  7. miooodek

    miooodek New Member

    I have done that, my work station use dns server 192.168.13.149 (server with isp conf)


    dig log:

    Code:
    ; <<>> DiG 9.6-ESV-R1 <<>> @localhost erpi.pl
    ; (2 servers found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 1687
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;erpi.pl.                       IN      A
    
    ;; Query time: 73 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Sun Aug 29 15:28:36 2010
    ;; MSG SIZE  rcvd: 25
    
    
    what's wrong?
     
  8. till

    till Super Moderator

    Which tutorial did you use to install the server?
     
  9. miooodek

    miooodek New Member

  10. till

    till Super Moderator

    Please post the output of the command:

    netstat -tap | grep dns
     
  11. miooodek

    miooodek New Member

    Output of the command: netstat -tap | grep dns

    Code:
    tcp        0      0 localhost:domain        *:*                     LISTEN      3132/dnscache
    tcp        0      0 192.168.13.149:domain   *:*                     LISTEN      2870/mydns
    tcp6       0      0 localhost:domain        [::]:*                  LISTEN      2870/mydns
    
     
  12. till

    till Super Moderator

    Ok. If you use dnscache as local resolver, then you have to use this command to query your dns server:

    dig @192.168.13.149 erpi.pl
     
  13. miooodek

    miooodek New Member

    output of command: dig @192.168.13.149 erpi.pl

    Code:
    ; (1 server found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 45247
    ;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0
    ;; WARNING: recursion requested but not available
    
    ;; QUESTION SECTION:
    ;erpi.pl.                       IN      A
    
    ;; ANSWER SECTION:
    erpi.pl.                86400   IN      A       192.168.13.149
    
    ;; AUTHORITY SECTION:
    erpi.pl.                86400   IN      NS      pielgrzym.erpi.pl.
    
    ;; Query time: 6 msec
    ;; SERVER: 192.168.13.149#53(192.168.13.149)
    ;; WHEN: Mon Aug 30 15:48:31 2010
    ;; MSG SIZE  rcvd: 65
    
    I think that's ok, but I still can't connect to the srv via domain name
     
  14. miooodek

    miooodek New Member

    ok, I found a sollution. After installing dnsmasq everything is working fine :)
     

Share This Page