how to fix: address not listed for hostname?

Discussion in 'Server Operation' started by Ovidiu, Jun 19, 2012.

  1. Ovidiu

    Ovidiu Active Member

    Debian perfect server installation with ISPCFG3 and 2 IPs.
    I added the second IP to my server as advised by Falko in another thread, then I started getting these warnings in my mail logs. To fix them, I added a reverse DNS entry for the second IP and thought I got rid of them but every now and then, these warnings still appear in my logs.


    85.214.249.219: address not listed for hostname h1870666.stratoserver.net

    My primary IP for this server is: 85.214.229.212
    Anything I forgot besides the reverse DNS?

    I also added the second IP to /etc/hosts like this but I am unsure if this is right:

    cat /etc/hosts
    127.0.0.1 localhost
    85.214.229.212 h1870666.stratoserver.net h1870666
    85.214.249.219 h1870666.stratoserver.net h1870666
     
  2. Ovidiu

    Ovidiu Active Member

  3. TiTex

    TiTex New Member

    do you have an A record for h1870666.stratoserver.net pointing to 85.214.249.219 ?
    your reverse dns is set up correctly both 85.214.249.219 and 85.214.229.212 are pointing back to h1870666.stratoserver.net , however you should also have a record like

    h1870666 IN A 85.214.249.219

    in your zone
     
  4. Ovidiu

    Ovidiu Active Member

    Just figured out the same thing! Chatted with my server provider's help desk and it turns out they suggest using one of my own domains.

    Not sure I understand this:

    they provide me with a server and a generic hostname, i.e. h1870666.stratoserver.net and 2 IPs but I can't use the second IP for sending emails because of the problem I reported in this thread.
    The problem is that you have absolutely no control over the DNS settings for hte domain they provide me with, i.e. I can't set up an A-record for h1870666.stratoserver.net

    Now my question is, if I use one of my own domains, to set up A-records and reverse DNS pointers, that would solve the problem, but I guess I would also need to change a lot of postfix configuration, right?

    So in my quest to elegantly solve this I came across this thread: http://www.faqforge.com/linux/send-all-outgoing-email-trough-one-ip-address-in-postfix/ explaining how to stop postfix sending emails through a particular IP but in the comment below, a user explains that that solution screws up AMAVIS and suggests a new solution.

    Does anyone know if the solution in the comment is the best way to go?

    for those too lazy to click the link, the suggested solution is to add
    to bind postfix to one IP but that seems to stop AMAVIS from working.

    The counter-solution in the comment section suggests editing /etc/postfix/master.cf:
     
  5. TiTex

    TiTex New Member

    tell me if i understand your setup

    you have bought a domain from a service provider
    that h1870666.stratoserver.net is one of the provider default NS's for your domain
    you are hosting your domain (zone) with the provider
    you are hosting your web/mail server on your own server or rented dedicated/vps
    you have an A and MX record in your zone pointing to your mail server IP

    is this correct ?
     
  6. Ovidiu

    Ovidiu Active Member

    I see I managed to confuse you :)

    What you said earlier is actually right:
    Strato, my root server provider, delivers each of their root servers with a domain name, i.e. h1870666 within the domain managed by them: stratoserver.net

    I have no control over this domain since its theirs, therefore I cannot add h1870666 IN A 85.214.249.219. so I guess its easier to simply have postfix use only my first IP for which they added the A record.

    To answer your questions above:
    - h1870666.stratoserver.net is the root server hostname and domain as assigned by the ISP
    - on this root server I run web server/dns/mail server
    - all domains I host are properly configured

    The point is that postfix is configured like this:

    myhostname = h1870666.stratoserver.net
    myorigin = /etc/mailname
    /etc/mailname contains: h1870666.stratoserver.net

    so I would have to reconfigure postfix completely if I were to replace h1870666.stratoserver.net with a domain I own and host.

    Therefore, I tried putting the problem like this:

     

Share This Page