How to enter ispconfig

Discussion in 'General' started by cruz, Apr 27, 2007.

  1. cruz

    cruz New Member

    I installed ispconfig, but I can not enter the panel. My domain is being transferred at this time. I used https: when I set it up. Can I turn off the ssl some ware to allow me to get to the panel?
     
  2. aqua

    aqua New Member

    You can use your server's ip address to access the admin page.

    Lets say your ip is: 192.168.1.100

    then type this into your browser: https://192.168.1.100:81

    this should bring up the admin page

    --aqua
     
  3. cruz

    cruz New Member

    no it will not work

    I tried that. It will not work. It brings up a Internet Explorer cannot display the webpage. I even opened port 81,80 on the router. I don't know how to get the panel to come up. I figured maybe it was blocking it. but it is on my intranet. I do not think the router has anything to do with it. Do you know anything else to try? :confused:
     
  4. cruz

    cruz New Member

    Apache

    I can reach apache with my ip address and :80 on the end. But it is under http:// not https:// . Maybe it has to do with the (s). Help!!
     
  5. negativais

    negativais New Member


    I have the same problem.
    Ican make PING, i can login using SSH, but when i typing in my web browser url https://....:81 iget error:

    ERROR
    The requested URL could not be retrieved

    While trying to retrieve the URL: 213.21.219.23:81

    The following error was encountered:

    * Access Denied.

    Access control configuration prevents your request from being allowed at this time. Please contact your service provider if you feel this is incorrect.

    Your cache administrator is root.


    Can anybody help me to solv these problom???? :( :(
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    @negativais

    The above error message is not from ISPConfig. So anything else blocks the requests. Please check the firewall on your server, desktop and router if access to port 81 is allowed.
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    No, the apache on port 80 has nothing to do with it. Please post the output of:

    netstat -tap

    and

    iptables -L
     
  8. edge

    edge Active Member Moderator

    It might also be that your certificate is corrupted. If so, than have a look here on how to create a new one
     
    Last edited: Apr 27, 2007
  9. negativais

    negativais New Member

    The output of netstat -tap

    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:mysql *:* LISTEN 4294/mysqld
    tcp 0 0 *:81 *:* LISTEN 20622/ispconfig_htt
    tcp 0 0 *:auth *:* LISTEN 4453/inetd
    tcp 0 0 *:ftp *:* LISTEN 20782/proftpd: (acc
    tcp 0 0 213.21.219.23:domain *:* LISTEN 20761/named
    tcp 0 0 localhost.locald:domain *:* LISTEN 20761/named
    tcp 0 0 localhost.localdoma:953 *:* LISTEN 20761/named
    tcp 0 0 *:smtp *:* LISTEN 20729/master
    tcp6 0 0 *:imaps *:* LISTEN 4425/couriertcpd
    tcp6 0 0 *:pop3s *:* LISTEN 4444/couriertcpd
    tcp6 0 0 *:pop3 *:* LISTEN 4430/couriertcpd
    tcp6 0 0 *:imap2 *:* LISTEN 4413/couriertcpd
    tcp6 0 0 *:www *:* LISTEN 20643/apache2
    tcp6 0 0 *:domain *:* LISTEN 20761/named
    tcp6 0 0 *:ssh *:* LISTEN 4546/sshd
    tcp6 0 0 ip6-localhost:953 *:* LISTEN 20761/named
    tcp6 0 0 *:smtp *:* LISTEN 20729/master
    tcp6 0 0 *:https *:* LISTEN 20643/apache2
    tcp6 0 288 ::ffff:213.21.219.2:ssh ::ffff:213.21.219:34339 ESTABLISHED19355/0

    and the output of iptables -L

    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination
     
    Last edited: Apr 27, 2007
  10. cruz

    cruz New Member

    here you go till

    login as: root
    [email protected]'s password:
    Last login: Thu Apr 26 22:36:07 2007 from 192.168.1.111
    [[email protected] ~]# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:841 *:* LISTEN 1931/rpc.statd
    tcp 0 0 *:mysql *:* LISTEN 15657/mysqld
    tcp 0 0 *:sunrpc *:* LISTEN 1889/portmap
    tcp 0 0 *:hosts2-ns *:* LISTEN 5900/ispconfig_http
    tcp 0 0 *:ftp *:* LISTEN 6061/proftpd: (acce
    tcp 0 0 192.168.1.156:domain *:* LISTEN 6038/named
    tcp 0 0 server1.apostolichea:domain *:* LISTEN 6038/named
    tcp 0 0 localhost.localdomai:domain *:* LISTEN 6038/named
    tcp 0 0 localhost.localdomain:ipp *:* LISTEN 3874/cupsd
    tcp 0 0 *:smtp *:* LISTEN 18127/master
    tcp 0 0 localhost.localdomain:rndc *:* LISTEN 6038/named
    tcp 1 0 server1.apostolichea:prizma ns1.centos.org:http CLOSE_WAIT 2335/python
    tcp 1 0 server1.apost:eek:bjectmanager ns1.centos.org:http CLOSE_WAIT 2335/python
    tcp 1 0 server1.apostoliche:e-dpnet ns1.centos.org:http CLOSE_WAIT 2335/python
    tcp 1 0 server1.apostolicheart:4278 75.174.92.64.static.re:http CLOSE_WAIT 2335/python
    tcp 0 0 *:imaps *:* LISTEN 4734/dovecot
    tcp 0 0 *:pop3s *:* LISTEN 4734/dovecot
    tcp 0 0 *:pop3 *:* LISTEN 4734/dovecot
    tcp 0 0 *:imap *:* LISTEN 4734/dovecot
    tcp 0 0 *:http *:* LISTEN 5925/httpd
    tcp 0 0 *:ssh *:* LISTEN 2198/sshd
    tcp 0 0 localhost6.localdomain:rndc *:* LISTEN 6038/named
    tcp 0 0 *:https *:* LISTEN 5925/httpd
    tcp 0 148 server1.apostolichearts:ssh ::ffff:192.168.1.111:4560 ESTABLISHED 1017/0
    [[email protected] ~]# iptables -L
    Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination
    [[email protected] ~]# clr
    -bash: clr: command not found
    [[email protected] ~]#
     
  11. falko

    falko Super Moderator ISPConfig Developer

    ISPConfig is running. Can you try both http://192.168.1.155:81 and https://192.168.1.155:81 ?
    Also, are there any errors in the error log in /root/ispconfig/httpd/log/?
     
  12. falko

    falko Super Moderator ISPConfig Developer

    ISPConfig is running here as well. Are there any errors in the error log in /root/ispconfig/httpd/log/?
     
  13. cruz

    cruz New Member

    is working now

    I reinstalled and now I am able to get into https://. It just gives me a warning, but I accepted the cert and got into the ispconfig. I give up on the key. I can not get it to work correct. Anyhow. thank you for the help.
     
  14. mfiendd

    mfiendd New Member

    Hello all,

    I'm having the same issue.

    I ran netstat -tap and I see ISPconfig is running.

    I then checked the error log and the results are listed below.

    [Sun May 20 17:29:35 2007] [notice] Apache/1.3.37 (Unix) PHP/5.2.1 mod_ssl/2.8.28 OpenSSL/0.9.8e configured -- resuming normal operations
    [Sun May 20 17:29:35 2007] [notice] Accept mutex: sysvsem (Default: sysvsem)
    [Sun May 20 17:30:16 2007] [error] mod_ssl: SSL handshake failed: HTTP spoken on HTTPS port; trying to send HTML error page (OpenSSL library error follows)
    [Sun May 20 17:30:16 2007] [error] OpenSSL: error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request [Hint: speaking HTTP to HTTPS port!?]
    sscldev1:~/ispconfig/httpd/logs# cat error_log
    [Sun May 20 17:29:35 2007] [notice] Apache/1.3.37 (Unix) PHP/5.2.1 mod_ssl/2.8.28 OpenSSL/0.9.8e configured -- resuming normal operations
    [Sun May 20 17:29:35 2007] [notice] Accept mutex: sysvsem (Default: sysvsem)
    [Sun May 20 17:30:16 2007] [error] mod_ssl: SSL handshake failed: HTTP spoken on HTTPS port; trying to send HTML error page (OpenSSL library error follows)
    [Sun May 20 17:30:16 2007] [error] OpenSSL: error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request [Hint: speaking HTTP to HTTPS port!?]
    [Sun May 20 17:35:32 2007] [error] mod_ssl: SSL handshake failed: HTTP spoken on HTTPS port; trying to send HTML error page (OpenSSL library error follows)
    [Sun May 20 17:35:32 2007] [error] OpenSSL: error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request [Hint: speaking HTTP to HTTPS port!?]
    sscldev1:~/ispconfig/httpd/logs# cat error_log
    [Sun May 20 17:29:35 2007] [notice] Apache/1.3.37 (Unix) PHP/5.2.1 mod_ssl/2.8.28 OpenSSL/0.9.8e configured -- resuming normal operations
    [Sun May 20 17:29:35 2007] [notice] Accept mutex: sysvsem (Default: sysvsem)
    [Sun May 20 17:30:16 2007] [error] mod_ssl: SSL handshake failed: HTTP spoken on HTTPS port; trying to send HTML error page (OpenSSL library error follows)
    [Sun May 20 17:30:16 2007] [error] OpenSSL: error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request [Hint: speaking HTTP to HTTPS port!?]
    [Sun May 20 17:35:32 2007] [error] mod_ssl: SSL handshake failed: HTTP spoken on HTTPS port; trying to send HTML error page (OpenSSL library error follows)
    [Sun May 20 17:35:32 2007] [error] OpenSSL: error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request [Hint: speaking HTTP to HTTPS port!?]

    From my understanding it looks like that the communication from the browser to the server is in HTTP when it's attempting to open & communicate in HTTPS.

    I'm not sure what I can do to futher troubleshoot this issue.

    Any help is greatly appreciated,

    MFiendD
     
  15. till

    till Super Moderator Staff Member ISPConfig Developer

  16. mfiendd

    mfiendd New Member

    Sorry Till, I forgot to note in my previous post that this issue is happening when I access via SSL (https) on port 81.

    When access with http of course I selected the option to use secure sockets it prompts to connect via https:.
     
  17. mfiendd

    mfiendd New Member

    Issue resolved. I re-created a new SSL cert and everything is working like a charm.
     

Share This Page