How to enable URL rewriting

Discussion in 'Installation/Configuration' started by bjarne-j, Nov 2, 2008.

  1. bjarne-j

    bjarne-j New Member


    I've made a .htaccess file with following content:

    RewriteEngine on
    RewriteRule ^(.+)/$ index.php 
    I'm trying to point everything to index.php, but it doesn't work. My server returns an 404 error.

    My server is configured as "the perfect server" guide describes(debian etch).

    Loaded Modules:
    core mod_log_config mod_logio prefork http_core mod_so mod_alias mod_auth_basic mod_authn_file mod_authz_default mod_authz_groupfile mod_authz_host mod_authz_user mod_autoindex mod_cgi mod_dir mod_env mod_include mod_mime mod_negotiation mod_php5 mod_rewrite mod_setenvif mod_ssl mod_status mod_suexec
    Does mod_rewrite have to be enabled somewhere else?

    Thanks in advance.
  2. Ben

    Ben ISPConfig Developer ISPConfig Developer

    I am not that sure of those rules, but afair + is only none or one character, so this would not work.
    But what do the access und error log tell?

    And you have to make sure that Allow Override contains "FileInfo" for the directory you place the .htaccess in.
    Last edited: Nov 2, 2008
  3. bjarne-j

    bjarne-j New Member

    Well, I got it to work. By editing the apache2.conf

Share This Page