How to enable Nginx FastCGI cache in ISPConfig3?

Discussion in 'Installation/Configuration' started by zenny, Mar 30, 2016.

  1. zenny

    zenny Member

    Hi,

    I added to one of the .vhost file the following:


    fastcgi_buffer_size 128k;
    fastcgi_buffers 256 4k;
    fastcgi_busy_buffers_size 256k;
    fastcgi_temp_file_write_size 256k;
    fastcgi_cache YOURAPP;
    fastcgi_cache_valid 200 60m;

    which looked like:

    location ~ \.php$ {
    try_files /48e3b99078ae2234ccd280a5e247557e.htm @php;
    }

    location @php {
    try_files $uri =404;
    include /etc/nginx/fastcgi_params;
    fastcgi_pass unix:/var/lib/php5-fpm/web9.sock;
    fastcgi_index index.php;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    fastcgi_intercept_errors on;
    fastcgi_buffer_size 128k;
    fastcgi_buffers 256 4k;
    fastcgi_busy_buffers_size 256k;
    fastcgi_temp_file_write_size 256k;
    fastcgi_cache YOURAPP;
    fastcgi_cache_valid 200 60m;

    }

    But that does not seem to work when I tried to reload nginx service!

    Is there a specific way to enable by default nginx fcgi cache in ispconfig3?
     
  2. Gwyneth Llewelyn

    Gwyneth Llewelyn New Member

    If you did add that manually on a specific .vhost file, then it will be rewritten by ISPConfig the next time you configure that website from the control panel...
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

Share This Page