How to enable FXP on ISPCONFIG 3?

Discussion in 'Installation/Configuration' started by crypted, May 11, 2010.

  1. crypted

    crypted New Member

    I want to enable FXP for the PureFTPD. I realize it has to be started with the -w -x flags (I believe anyway). However, I cannot find the configuration file for the life of me. Everything refers back to PURE-FTP-MYSQL.

    Can someone please help me out? Tell me where the config files are, or how to start the daemon with such flags?

    I'm using Debian Lenny.
  2. CSsab

    CSsab New Member

    [email protected]:~# whereis pure-ftpd
    pure-ftpd: /etc/pure-ftpd /usr/share/man/man8/pure-ftpd.8.gz

    You would have to use one of the configuration files in /usr/share/man/man8/ if you wanted ftp starting with a perl wrapper from command line but to make these flags default for your ISPConfig users you'd have to work the flags into the ISPConfig scripts.

    EG: the normal flag for "don't resolve" is -H or "--dontresolve" I think and if you take a look at:

    [email protected]:/etc/pure-ftpd/conf# ls
    AltLog BrokenClientsCompatibility ChrootEveryone DontResolve FSCharset MinUID MySQLConfigFile NoAnonymous PAMAuthentication PureDB UnixAuthentication
    [email protected]:/etc/pure-ftpd/conf# cat DontResolve
    [email protected]:/etc/pure-ftpd/conf#

    we don't get to see configuration files in a user's directory because ftp sends passwords in clear test - so the files are chrooted to that user.

  3. JohnMichealx

    JohnMichealx New Member

    found out how to enabe FXP on pureftpd

    pico /etc/sysconfig/pure-ftpd

    go to the end of the file and add under

    # read the fine manual or ask the mailing-list.



    hope help :D

Share This Page