How to edit server host name ip address in ssl redirection page ???

Discussion in 'Installation/Configuration' started by ffs123, Nov 2, 2011.

  1. ffs123

    ffs123 New Member

    I install Beta version and I put FQDN server host name when I install, but host name was not propagating well.

    SSH output
    Stopping httpd: [ OK ]
    httpd: apr_sockaddr_info_get() failed for
    httpd: Could not reliably determine the server's fully qualified domain name, using for ServerName
    [Tue Nov 01 09:48:18 2011] [warn] NameVirtualHost *:80 has no VirtualHosts
    Starting httpd: [ OK ]
    Stopping pure-ftpd: [ OK ]
    Starting pure-ftpd: [ OK ]
    Installation completed.
    [[email protected] install]#


    I turn on ssl feature.
    When I type http://myhostname:8080/ in address bar,
    Url redirect to ssl page and shows as below.


    Bad Request

    Your browser sent a request that this server could not understand.
    Reason: You're speaking plain HTTP to an SSL-enabled server port.
    Instead use the HTTPS scheme to access this URL, please.



    Please help me how to edit to my host name or Public Static IP address. Server is in datacenter. My host name was not propagating well when I install the ispconfig beta version.

    Hint should be https://punlicipaddress:8080/

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Edit the file /etc/hosts and add the public IP of the server and hostname there. Please see also the perfect setup guides, the step to edit your hosts file is described there.

    By the way, your problem is not related to the use of the ISPConfig beta on the server.
  3. ffs123

    ffs123 New Member

    add ServerName YOURSERVERNAME to httpd.conf

    I found the solution.
    This is for Centos 5.7 64 bit. not sure to work for other linux.
    login as root

    vi /etc/httpd/conf/httpd.conf

    uncoment or add following line in httpd.conf

    ServerName example dot com :80


    /etc/init.d/httpd restart

Share This Page