How to downgrade mysql5x to mysql 4.1.7

Discussion in 'HOWTO-Related Questions' started by achun777, Jul 8, 2009.

  1. achun777

    achun777 New Member

    I need to install mysql 4.1.x version in my centos 5.3 can any one tell me how to do that .
    I have removed the mysql 5.x.x version using
    #yum remove mysql

    I tried to install rpm version
    #wget http://www.oborona.net/stuff/MySQL-server-5.0.16-0.glibc23.i386.rpm
    #rpm --nodeps -ivh MySQL-server-4.1.22-0.glibc23.i386.rpm
    but after installing when I run
    #service mysql start
    Starting MySQL[ OK ]
    #mysql -v
    command not found
    an I doing something wrong here

    then when i try installing binary version i get this error
    _____________________________________________
    ./scripts/mysql_install_db: line 85: ./bin/my_print_defaults: cannot execute binary file
    ./scripts/mysql_install_db: line 151: /usr/bsd/hostname: No such file or directory
    Neither host '' nor 'localhost' could be looked up with
    ./bin/resolveip
    Please configure the 'hostname' command to return a correct hostname.
    If you want to solve this at a later stage, restart this script with
    the --force option
    ________________________________________________

    I am not sure what to do. can anyone throw some bright light!!!

    Thank you
    Pamei pouchunlung
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    You must install the MySQL client package as well.
     

Share This Page