How to disable SORBS/XBL/NJABL

Discussion in 'Installation/Configuration' started by MvincM, Apr 25, 2006.

  1. MvincM

    MvincM New Member


    I would like to use spamassasin but I can't use SORBS/XBL/NJABL. Many of my server users are dynamic ip user (which are blacklisted). In this case eaven if they mailing each other mails are signed as spam.

    Pyzor, Razor, DCC and Bayes are just fine for me to track the SPAM. I would like to disable SORBS/XBL/NJABL and others.

    I don't know how to do this.

    I have commented out the line:

    #loadplugin Mail::SpamAssassin::plugin::URIDNSBL

    in /home/admispconfig/ispconfig/tools/spamassassin/etc/mail/spamassassin/init.pre

    but it doesn't help. Maila are still mark as spam:

    2.0 RCVD_IN_SORBS_DUL RBL: SORBS: sent directly from dynamic IP
    [ listed in]
    3.1 RCVD_IN_XBL RBL: Received via a relay in Spamhaus XBL
    [ listed in]
    1.7 RCVD_IN_NJABL_DUL RBL: NJABL: dialup sender did non-local SMTP
    [ listed in]

    So now I must turn off spam engine a all.

    Please help. What to do?

    Best regards,
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You can enable / disable blacklists and enable razor, dcc and pyzor in the file:


    skip_rbl_checks 1 # (0|1)
    use_razor2 1
    use_dcc 1
    use_pyzor 1
    dcc_add_header 1

    These global settings can be overriden by entries in the .user_prefs file in the home directorys of the users.
  3. MvincM

    MvincM New Member

    Thanks a lot ! It should works.

    I will check it as soon as I will get my server back... A lot of servers from is down for a couple of days (mine as well).

    Best regards
  4. minskog

    minskog New Member

    I don't have this lines. If i need to use this blacklists is necessary write this lines to that file or the default is on?
  5. falko

    falko Super Moderator ISPConfig Developer

    You have to add these lines.

Share This Page