How to disable postfix/smtpd ?

Discussion in 'General' started by itstudio7777, Mar 21, 2022.

  1. itstudio7777

    itstudio7777 Member

    Hello !

    My server is debian 10, apache with ispconfig 3.

    I want to remove / disable postfix/smtpd because I have too many requests for this, maybe hachers...
    Because of that my CPU is overloading and I want to remove / disable this option for all of my websites.

    Can you help me to resolve this problem?
     
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Not sure what you're wanting there, to disable your MTA or prevent websites from sending mail?
     
  3. itstudio7777

    itstudio7777 Member

    I want to disable MTA
     
  4. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Should be
    Code:
    systemctl stop postfix; systemctl disable postfix
    and then disable any monitoring which might restart it (eg. under System > Service Config and anything you may have setup like monit).
     
  5. itstudio7777

    itstudio7777 Member

    I have tried this command but on ispconfig system log is showing again postfix logs
     
  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    How did you try it? What happened?
    Is postfix running? If you stopped postfix and it stays stopped, it should no longer make new log lines.
     
  7. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Perhaps you get new logs from local submissions, rather than from smtp? What does "systemctl status postfix" show?
     
  8. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    You can just close the firewall for email ports.
     
  9. Shyciii

    Shyciii New Member

    Try:
    systemctl stop postfix; systemctl mask postfix
     

Share This Page