How to disable pop3 service warning

Discussion in 'Installation/Configuration' started by webmaser, Apr 25, 2014.

  1. webmaser

    webmaser New Member


    I'm using last version of ISPConfig.
    I have configured dovecot that I use only IMAP - not POP3, but ISPConfig shows warnings that one of some services are offline - pop3.

    I can't disable MAIL service monitoring in Server services setup because I want to monitor SMTP and IMAP.

    Are there any possibilities to configure that to not show this warning?
    Or I have to modify ISPConfig sources? - Can someone provide information where I can find it?

    Thank you.
  2. srijan

    srijan New Member HowtoForge Supporter


    There are currently 3 options:

    1) Stop the daemons and get a warning that they are not running.
    2) Close the pop3/pop3s firewall ports and get no warning.
    3) Change the ispconfig code of the monitor system.

  3. webmaser

    webmaser New Member

    Thank you Srijan,

    I really need to have the deamon stopped so that I will need to change ISPConfig code.

    Can anybody help me where I can found & make the change to hide/disable that warning?

    Thank you.
  4. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Around line 720
            /* Monitor POP3-Server */
    $data['pop3server'] = -1// unknown - not needed
    if ($services['mail_server'] == 1) {
                if (
    $this->_checkTcp('localhost'110)) {
    $data['pop3server'] = 1;
                } else {
    $data['pop3server'] = 0;
    $state 'error'// because service is down
  5. webmaser

    webmaser New Member

    Thank you Croydon, this is what I was looking for.

Share This Page