How to disable "open_basedir"

Discussion in 'Installation/Configuration' started by blax, Sep 9, 2014.

  1. blax

    blax New Member

    Hello,

    I would like to disable PHP option "open_basedir" for a website, but if I delete the "open_basedir" field in website Options tab and save, no change take effect and it still remain active.

    I know that I can put the "/" path in open_basedir but this way is not really disabled. I want to just have this field empty to be sure it is really disabled.

    Thank you.

    Roberto
     
    Last edited: Sep 9, 2014
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to put the word "none" in the open basedir field.
     
  3. blax

    blax New Member

    Thank you, it worked. ;)
     
  4. ART3D

    ART3D New Member

    Hi Till
    I'm new to the forum, so hello everyone.
    The post is a bit old but I hope you are still there.
    I would like to ask open-basedir off.
    But my ispconfig version does not allow me just with the simple "none"
    The value entered for my site is:

    /var/www/clients/client1/web23/web:/var/www/clients/client1/web23/private:/var/www/clients/client1/web23/tmp:/var/www/chinadirec.fr/web: /srv/www/chinadirec.en/web:/usr/share/php5:/usr/share/php:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/usr/ Share / php

    How to change this, to give it the value "none" or off

    A big thank-you
     
  5. sjau

    sjau Local Meanie Moderator

    is there a good reason to disable open-base dir? I can't think of any.
     
  6. ART3D

    ART3D New Member

    Yes i did it now
    i did not know why i did'nt see that Till already told it. many thanks
     
  7. ART3D

    ART3D New Member

     
  8. ART3D

    ART3D New Member

    I wanted to run an installation script on a sub-domain of a Dedicated-Virtual server hosted by Media Temple with a Plesk 7.5.4, but received the following php error message when I ran the script:

    Warning: file_exists(): open_basedir restriction in effect.

    Reason why the error occurs

    The reason for this error is because, php safe mode is turned on and because the open_basedir is set for each sub-domain. After quite a lot of searching on the web,
     
  9. ART3D

    ART3D New Member

    FOR PROGRAMS WHICH MANAGES MUCH DATA AT THE TIME; THIS REQUIRED WHEN, IT MUST MANAGE VARIOUS APIs IN SIMULTANEOUS CURRENCIES AND INSENTANNED TRANSLATION THAT BLOCKS EVERYWHERE
     

    Attached Files:

Share This Page