How to disable / hide Send copy to

Discussion in 'ISPConfig 3 Priority Support' started by pawan, Apr 5, 2016.

  1. pawan

    pawan Member HowtoForge Supporter

    How to disable / hide send copy to option in mail box page.
    What is happening is If am setting a send copy to -email address outside the server for example a abc@gmail.com in pkjoshi@mywebsolutions.co.in then a mail sent from say xyz@microsoft.com is being sent using SMTP of my server as if the mail is originating from my server that is from xyz@microsoft.com.
    I am using relay server and in no way I can validate this address i.e. xyz@microsoft.com and there will be numerous instances of outside sender sending mail to pkjoshi@mywebsolutions.co.in and those senders are becoming senders from my server and postfix is alllowing it as relay email address of pkjoshi@mywebsolutions.co.in
    So either the from address is changed to pkjoshi@mywebsolutions.co.in with some header as xyz@microsoft.com or I am able to completely take that option off of - send copy to.
    Thanks.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The only option to remove the checkbox is to alter the html template of that page. Or you change the sieve code and remove it from the sieve template to mimic the behaviour that you want.
     
  3. pawan

    pawan Member HowtoForge Supporter

    Hi Till,
    What is the best way to override the html template of the page so that it is not get over written on update.
    I think the file required to be altered is /usr/local/ispconfig/interface/web/mail/templates/mail_user_mailbox_edit.htm
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Create a custom theme, custom themes can override form templates as well.
     

Share This Page