How to disable CREATE DATABASE in phpmyadmin?

Discussion in 'General' started by mrtnzlml, Sep 20, 2014.

  1. mrtnzlml

    mrtnzlml New Member

    Hi, I have strange problem. We find out, that it's possible to create database using phpmyadmin. But this is not what I want. Unfortunately on another installation it works fine. User cannot create database using phpmyadmin, just via ISPC (that's what I want). How can I setup this behavior to the database server? How to disable "CREATE DATABASE" for all users in phpmyadmin? I cannot find any solution...

    Thanks for your help. (-:
  2. leiw

    leiw Member


    I just checked my database client cannot create new database in phpmyadmin.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    clients cant create new databases in phpmyadmin. Only when you as administrator login tinto phpmyadmin as root user, then you can create new databases off course.
  4. mrtnzlml

    mrtnzlml New Member

    Ok, this is weird and scaring me much more now. There must be something really wrong, because I created few users in ISPC and they are able to create databases in phpmyadmin or adminer...

    How to fix this issue? It's badly configured mysql server?
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Maybe someone modified a mysql user afterwards and granted additional permissions with phpmyadmin?

    I just tested this with ispconfig and all permissions are set correctly.
    There is a user in the mysq.user database were all permissions are set to "no" and then a database record in the mysql.db table is added were everything is set to "yes" except of "Grant_priv" as we dont want to allow the user to give himself more permissions.
  6. mrtnzlml

    mrtnzlml New Member

    • mysq.user - all permissions set to N
    • mysql.db - all permissions se to Y except Grant_priv

    Seems ok. But I found out another interesting thing. It depends on database name:

    • mycustomname -> cannot create
    • test -> created
    • tester -> cannot create
    • test_customname -> created

    So there is another question. Why? And how to disable creation of database with name "test" or with prefix "test_"?
  7. mrtnzlml

    mrtnzlml New Member

Share This Page