How to disable completely Jailkit for Cron jobs?

Discussion in 'Installation/Configuration' started by jvargas, May 26, 2012.

  1. jvargas

    jvargas New Member


    I do not want my cronjobs to be run with Jailkit, and I don't have it installed because I don't want it.


    But even if I disable the SSH User from running using Jailkit, Cronjobs always try to be run using Jailkit and then fails.


    I noticed there is a cron file created in:

    And inside it, it always forces the shell to use jailkit, by setting the SHELL variable:

    So, any shell command always fails since Jailkit is not installed.

    Question is:

    How can I tell IspConfig to disable or avoid using Jailkit for Cronjobs?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Go to clients, select the client and allow non jailed cronjobs on the limits tab.
  3. thomasso

    thomasso New Member

    I'm running into the same issue.
    ISPC 3.1.6
    tried to add a user cron via the web gui.
    First it added a jailkit shell cron job for the user. OK, I disabled it in the Clients/Limits section, but no change in the cron file. (Even if I recreate the job)
    any suggestions?
    UPDATE: I've modified the cron job to use http:// instead of direct PHP file access, it seems working now :)
    Last edited: Aug 25, 2017
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Existing crons will not be changed. you have to set it to full cron before you create the cronjob. Using a URL cron as you did now is the better method anyway as it is more secure.
  5. thomasso

    thomasso New Member

    thanks. seems okay now. It was not obvious how to add the command line on the web GUI. now it's clear.

    One more thing:
    If I add 2 URLs for the same domain it has a common wget output log, so only the latest will be visible.
    sometimes it's useful to see the output, maybe a parameter should be useful here (wget output file)

Share This Page