How to disable checking DNS_FROM_AHBL_RHSBL

Discussion in 'Installation/Configuration' started by g00fy, Jan 11, 2015.

  1. g00fy

    g00fy New Member

    The last few days I get a lot of false spam notifications from DNS_FROM_AHBL_RHSBL. What is the best way to disable checking this RBL with an ISPCONFIG3 installation?

    Should I put score DNS_FROM_AHBL_RHSBL 0 in local.conf from spamassassin, or whil that be overwritten when I make change from ISPCONFIG?

    Thanks for shining some light on this!
     
  2. florix.net

    florix.net Member

    Yess, I am also facing same problem today.

    X-Spam-Status: Yes, score=4.533 tagged_above=1 required=4.5
    tests=[BAYES_00=-1.9, BUG6152_INVALID_DATE_TZ_ABSURD=0.766,
    DKIM_ADSP_ALL=0.8, DNS_FROM_AHBL_RHSBL=2.699,


    how can we disable DNS_FROM_AHBL_RHSBL ?

    I checked their website, they are closing the list from 1st Jan 2015.
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you try to run

    sa-update

    to get the latest soamassassin updates and then restarted amavisd. Most likely they removed the disabled RBL already.
     
  4. florix.net

    florix.net Member

    Dear Till,

    When I run this command
    [[email protected] ~]# /usr/bin/sa-update

    netset: cannot include 0:0:0:0:0:0:0:1/128 as it has already been included
    netset: cannot include 0:0:0:0:0:0:0:1/128 as it has already been included
    netset: cannot include 0:0:0:0:0:0:0:1/128 as it has already been included
    netset: cannot include 0:0:0:0:0:0:0:1/128 as it has already been included
    netset: cannot include 0:0:0:0:0:0:0:1/128 as it has already been included
    netset: cannot include 0:0:0:0:0:0:0:1/128 as it has already been included
     
  5. florix.net

    florix.net Member

    Dear Till, Any update on this?

    My all emails are being marked as spam because of AHBL_RHSBL... is there is way I can remove it manually?
     
  6. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    You can add
    score DNS_FROM_AHBL_RHSBL 0
    to your local.cf
     
  7. florix.net

    florix.net Member

    Dear Florian.

    I have added that in local.cf in
    /etc/mail/spamassassin/local.cf

    Still I see header score for this check above 2
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you restart amavisd?
     
  9. g00fy

    g00fy New Member

    sa-update and restarting amavisd has solved it for me.
     
  10. Loveless

    Loveless Member

    Is there another way to easily change value per list and change the used DNSBL/RBL lists within ISPconfig now? I saw the post about postscreen doing it, but unfortunately I can't currently limit my users to port 587. Spamassassin seems to be able to do it too, at least give it a score per RBL, like I've done at the bottom here using mailspike.
     
  11. Jesse Norell

    Jesse Norell Well-Known Member

    No, the rbl setting in ISPconfig does an outright block on any match, which makes it much less useful (ie. you can't use many "lower quality" blacklists, because they'll false positive match sometimes and block - if you can score those lower, they won't be a problem). You mentioned two solutions (postscreen and spamassassin scores), another would be to find a postfix policy daemon that does rbl lookups; I've never looked for or used one offhand, but policyd-weight really stands out as an option in a quick google search.
     

Share This Page