How to debug remoting Error 500

Discussion in 'Installation/Configuration' started by krakoukas, Nov 13, 2007.

  1. krakoukas

    krakoukas New Member

    I have a 500 Error on server side during remoting "client add".
    Activating php log in /root/ispconfig/php/php.ini doesn't give info on this error?

    Is there a way to activate debug for remoting?

    Thanks for help
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Everything related to a 500 error must be logged in the apache log, php will not log this as php itself failed and can not log this.

    No and this wont help much in this case as the php script is not run.
  3. krakoukas

    krakoukas New Member

    Hi till,

    I feel depressed with your answer... I am in front of a wall and cannot pass through it!
    As you told me Error 500 means that php is not executed, but how do you explain that my client is created by ISPconfig remoting when apache returns this Error?
    php code is executed somewhere... So I should be able to debug it?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please have a look at the log that you posted in your other thread. There were 2 post requests, the first one succeeded and created the client, only the second one failed witha 500 error.
  5. krakoukas

    krakoukas New Member

    I know,
    First POST consists of remoting connexion to get soap_client reference and session_id and it works.
    Second POST is kunde_add call and returns error 500 while creating the client...

    It seems that remoting cannot return its error because of an error in ispconfig_soap.obj.php
    Any idea to bypass this?
    Last edited: Nov 14, 2007
  6. krakoukas

    krakoukas New Member


    Thanks till for finding this:

    If I comment out the following lines in the english
    language file /home/admispconfig/ispconfig/lib/lang/en.lng:
    everything is working fine. But the lines do not contain a syntax error, so I guess it must be a bug in the PHP interpreter itself, as it fails when it shall replace the $s variables.
    It does not affect your sytstem when these lines are commented out in en.lng, as your system is set to french locale and the en.lng file is only loaded for the remoting part and the remoting part does not need these 3 lines.
  7. mark0168

    mark0168 New Member

    I am facing the similar problem..
    I can't find the lines mentioned on the threads.

    I can create clients and the sites by Remote API but have problem to create the database of the site by Remote API.

    The error shows " no data present after HTTP headers "

    I can see the database is existed on ISPCONFIG admin panel but there is none existed in server.

    Therefore, the database and its user is not really established in server by Remote API.

    The only successful way I tried was to create a site by Remote API first.
    Waiting the site was shown on ISPconfig admin panel, I use Remote API to create the database after then it worked.

    Therefore, I tried to make it sleep for 15 seconds after creating the site and then create the database, it still failed.
    I am frustrated by this, does Remote API only control ISPconfig itself okay but fail to control server?
  8. till

    till Super Moderator Staff Member ISPConfig Developer

Share This Page