How to create nameservers in ISPConfig?

Discussion in 'ISPConfig 3 Priority Support' started by Matthias Reich, May 4, 2020.

  1. Matthias Reich

    Matthias Reich Member HowtoForge Supporter

    Hello,

    The following are the records in my ISPConfig as seen in the attached file. On the domain registrar side, I've changed the nameservers to ns1.domainname.com and ns2.domainname.com.
    I've also created hostnames with ns1 and ns2 with the server IP address. Can you please tell me where am I going wrong?

    Thanks.
     

    Attached Files:

  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. till

    till Super Moderator Staff Member ISPConfig Developer

    The records are fine so far. Take care to set the IP addresses of the name servers at your registrar as well, that's named glue records and is required when the zone of the name server is hosted on itself.
     
  4. Matthias Reich

    Matthias Reich Member HowtoForge Supporter

    Thanks till. That is done as well. Have a look at the screenshots here:
    SNAG-0583.jpg SNAG-0582.jpg SNAG-0584.jpg

    The DNS records are automatically generated on the registrar-side. I'm not sure if it is using them. When I click on that, it looks like this: SNAG-0585.jpg
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    I've tested your domain at intodns.com and it seems as if your dns server doe snot respond at the moment. Please check if the zone file of that zone has a .err file ending, zone files are normally stored in /etc/bind/ or /etc/named/ folder. This would indicate that BIND rejected the zone.
     
  6. Matthias Reich

    Matthias Reich Member HowtoForge Supporter

    Apparently both the directories are non-existent. I've used Perfect Server Tutorial for Debian 9. Where else can I look?
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    You can find the actual BIND zone directory in ISPConfig under System > server config.
     
  8. Matthias Reich

    Matthias Reich Member HowtoForge Supporter

    It mentions the same path which you've mentioned but the directory is non-existent. Should I try re-installing bind?
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, please reinstall BIND like this:

    apt-get install --reinstall bind9

    then check if the directory is there. If that's ok, then you probably have to update ISPConfig with reconfigure services = yes during update and then run Tools > resync in ISPConfig on dns to write out the dns zone again.
     
  10. Matthias Reich

    Matthias Reich Member HowtoForge Supporter

    Where can I find the 'reconfigure services = yes' option?

    EDIT: When I try to update ispconfig I get
    "There are no updates available for ISPConfig 3.1.15p3"
     
    Last edited: May 5, 2020
  11. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  12. Matthias Reich

    Matthias Reich Member HowtoForge Supporter

    That fixed it. Thank you very much Till and Taleman. You guys are life-savers!
     
    till likes this.

Share This Page