how to create a language package?

Discussion in 'Developers' Forum' started by flourishing, Dec 10, 2005.

  1. flourishing

    flourishing ISPConfig Developer

    how to create a language package?
     
  2. till

    till Super Moderator

    You will have to start with an existing anguage pack, e.g english (en). If you want to build e.g a finnish translation, make a copy of all en.lng files above the directory:

    /home/admispconfig/ispconfig/

    and name the files fi.lng. Then translate the contents. Only the string on the right side of the "=" of course ;-)
     
  3. flourishing

    flourishing ISPConfig Developer

    after that the language fl with come to a option in tools--language ?

    and i haven't found any lang file in that directory
     
  4. falko

    falko Super Moderator

  5. till

    till Super Moderator

    Yes.

    They are not IN the directory, there are in many directories above this path!

    run:

    locate en.lng

    to get a listing of all english language files.
     
  6. flourishing

    flourishing ISPConfig Developer

    not really .


    i have create cn.lng in that directories. but i can 't find the option cn in

    tools --language.

    what is the more steps to make the new cn.lang can be displayed in tools---language???
     
  7. till

    till Super Moderator

    There are no more steps, but you have not created all lng files. You missed the master language file:

    /home/admispconfig/ispconfig/lib/lang/cn.lng
     
  8. flourishing

    flourishing ISPConfig Developer

    yeah. i missed that file in isp .

    and now it works .
    but most parts of gui works fine .but some displayed mess.

    such as first line and the text under the button . where i can modified it ?
     
  9. till

    till Super Moderator

    I dont know which text under which button you mean. All texts are in the language files.
     
  10. flourishing

    flourishing ISPConfig Developer

    yes i know all the text are in lang file

    except the button and the first line text displayed mass , i don'know why ,but the other works fine.

    see this jpg
     

    Attached Files:

    • 12.gif
      12.gif
      File size:
      17.3 KB
      Views:
      392
    Last edited: Dec 11, 2005
  11. flourishing

    flourishing ISPConfig Developer

    thanks i already knew it .
     

Share This Page