How to connect to a new website and FTP-account?

Discussion in 'Installation/Configuration' started by kramer65, Jun 1, 2012.

  1. kramer65

    kramer65 New Member

    Hello,

    Using this guide I set up an Ubuntu server in a virtualbox instance. I can access the server through ssh and by going to http://192.168.1.67 in my guestOS (also Ubuntu 12.04). I can also enter ISPConfig and in there I added a site: test.com. I can see the folder it created: /var/www/test.com and I copied the /var/www/index.html in there. When I go to http://192.168.1.67/test.com however, I get a '403 Forbidden' error.

    So my first question: how can I access the files of a newly created website?

    I then also created an FTP-account and filled in the details in Filezilla. When I try to connect though, I get the following:
    So my second question: what am I doing wrong here? How can I connect to an FTP-account?

    I hope someone can hint me in the right direction. All tips are welcome!
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Enter the domain name in your browser, e.g.:

    http:/test.com/

    This can not work, use the domain name and not ip address to access the site. If you havent created the domain in dns yet, see here:

    http://www.faqforge.com/linux/contr...ess-a-namebased-website-without-a-dns-record/

    You have to use the full username incl. prefix as it is shown in the ftp user list in ispconfig.
     
  3. kramer65

    kramer65 New Member

    Thanks! It somehow added the prefix 'default' so the username became defaultkramer65. I can now login perfectly well! Is there actually a way to change this prefix into something like my domain name?

    I obviously don't actually own test.com, so if I enter test.com I simply go to the real website with the url test.com, not to my own setup.

    I changed /etc/hosts into the following:
    Code:
    127.0.0.1       localhost.localdomain   localhost
    192.168.1.67    www.test.com             server1
    I tried going to test.com again, but that leads me again to the real website with the url test.com, instead of my own server.

    Shouldn't it in the end always be possible to visit a website by it's ip-address instead of it's domain name? Do you have any other tip, or am I simply totally misunderstanding you? :confused:
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    See System > Interface config and the decription of the prefixes in the manual. Using the domain name is not possible as its bad idea to use a variable that will break yours etup when you change a website domain.

    You changed the file on the wrong server. The faq said to edit the hosts file on the workstation were you are working on, not the server.

    Yes, thats possible but not in the way you tried it. First, you have to assign the IP address and not * to the website in ispconfig and then you must ensure that no other website uses the same IP as apache cant decide otherwise which website to show and then you cann access the site by entring this in the browser:

    http://192.168.1.67/
     
  5. kramer65

    kramer65 New Member

    Great! Thanks!

    Ahh, nou I get it. I simply redirect all requests for test.com to that ip-address. Just fixed it and that indeed works like a charm, and looks nice as well! :)

    I had a look at the website in ISPConfig. The dropdown behind 'IP-Address' indeed says '*' now. But there is no other option in the dropdown. Would you possibly know where I can add my ip-address so that I can add it to my website? :eek:
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    System > Server IP
     
  7. kramer65

    kramer65 New Member

    Ah, I added the ip-address and then added it to the website. When I now go to the ip-address 192.168.1.99 it still redirects to the base installation and simply shows /var/www/index.html . This however, is not defined in ISPConfig as a website and I therefore cannot disable it in there.

    Any idea how I can disable the ip for the base apache webpage and redirect it to test.nl?
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Have you waited a minute until you tested the setup? The config cronjobs runs only once a minute, you can see in the ispconfig monitor > jobqueue when its finished.

    If the above is not the resaon, then there must be a vhost for this ip already in apache.Please check the default vhost from ubuntu in /etc/apache2/sites.available if it uses * or the IP address in the <virtualhost ....> line. if it uses the ip, then replace the IP with * and restart apache.
     
  9. kramer65

    kramer65 New Member

    Ah, yes, the cron-job seemed to be it. Thank you so much!

    I've used Cpanel and Direct Admin for the last 10 years, but if a little email-test also comes out positive I think from now on I'll use ISPConfig.. :)

    Thanks for creating it! (I think you are one of the developers behind it right?)
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, I'am a developer of the ispconfig software.
     

Share This Page