How to configure ISPConfig 3.1 with IPV6?

Discussion in 'Installation/Configuration' started by Stanislav Panayotov, Sep 30, 2016.

  1. Stanislav Panayotov

    Stanislav Panayotov New Member

    Hello,
    Today I install new cool version of ISPConfig - ISPConfig 3.1 on my Debian 8 stable. From ISPConfig 3.1 I go to System / Server Config. I use both IPV4 and IPV6 on my hosting server, but there is only IPV4 settings. There is field named "IP Address" but it working only with IPV4 address. There is not fields named "IP V6 Address" and "IP V6 Gateway", there is only field named "IPv6 Prefix". Please, tell me how to set properly my Debian with ISPConfig 3.1?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The IPv6 addresses are configured in the /etc/network/interfaces file on Debian, you don't have to add them in ISPConfig under System > Server config.
     
  3. Stanislav Panayotov

    Stanislav Panayotov New Member

    Thanks, but when I reconfigure my server via ISPConfig all IPV6 settings in /etc/network/interfaces are cleared.
     
  4. RalphGL

    RalphGL New Member

    I have the same problem. The complete settings in /etc/network/interfaces in section "iface eth0 inet6 static" are removed each time i reconfigure ISPConfig. In ISPConfig (3.1.2) the setting for "IPv6 Prefix" is empty - is that correct?
     
  5. Stanislav Panayotov

    Stanislav Panayotov New Member

    Yes, it's a total wrong. There are no any fields for IPv6: IP, netmask, Gateway, DNS. If your server is working only with IPv6 - with current version of ISPConfig (3.1.2) is not possibility to set any right IPv6 settings.
     
  6. RalphGL

    RalphGL New Member

    Ok, so i configure it manually. The problem is: the IPv6 entries will be removed (Debian Jessie). As i read here: https://git.ispconfig.org/ispconfig/ispconfig3/issues/4295
    Till suppose to deactivate the Network configuration checkbox under System > Server config.
    I will do so. But IMHO the IPv6 entries should not been removed (on a debian stable-system) even if the network configuration is activated in ispconfig. This is a workaround. I donĀ“t understand why Till think it is "not a bug" - maybe IPv6 in ISPConfig is just a "not feature". ;)
     
    Last edited: Feb 9, 2017
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    IPv6 addresses get added under System > Server IP. Click on "Add new IP address", enter the IP address in the IP field, select IPv6 as type and press save.
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    You can do that as well if you prefer that over automatic configuration. But then you should not enable the checkbox for automatic network configuration under System > server config as this checkbox instructs ispconfig to remove all manually made changes from the network config files.
     
  9. RalphGL

    RalphGL New Member

    Thanks Till. But it looks like a bug for me. On my system the IPv6 address is added under System > Server IP. But if the network configuration checkbox under System > Server config is activated all IPv6 entries in /etc/network/interfaces will be removed.
     
    Last edited: Feb 9, 2017
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    As soon as you enable the network configuration checkbox then you tell ISPConfig to remove all manually made settings from that file and that's exactly what happened.

    If you want to do manual changes in a config file that is managed by ispconfig then always the same procedure applies:

    1) Copy the config file template that you want to alter from /usr/local/ispconfig/server/conf/ to /usr/local/ispconfig/server/conf-custom/. In your case, the file is debian_network_interfaces.master
    2) Do your manual edits the the file that is on the conf-custom folder
     
    RalphGL likes this.

Share This Page