How to configure DNS templates

Discussion in 'Installation/Configuration' started by riccardobenetti, Jan 9, 2011.

  1. riccardobenetti

    riccardobenetti New Member

    Good afternoon,
    I saw that I set in ISPConfig 3 DNS templates, and I wonder if the two models below are correct and if not how can I fix so I can have templates for clients using Google Apps customers and do not use it, follow the templates I have:

    Default template:
    [ZONE]
    origin = {} DOMAIN.
    ns = ns1.vidit.com.br.
    mbox = {EMAIL}.
    refresh = 28800
    retry = 7200
    expires = 604800
    minimum = 3600
    ttl = 14400

    [DNS_RECORDS]
    A | {} DOMAIN. | {ip} | 0 | 86400
    A | www | {ip} | 0 | 86400
    A | mail | {ip} | 0 | 14400
    NS | {} DOMAIN. | ns1.vidit.com.br. | 0 | 14400
    NS | {} DOMAIN. | ns2.vidit.com.br. | 0 | 14400
    NS | {} DOMAIN. | ns3.vidit.com.br. | 0 | 14400
    MX | {} DOMAIN. | mail. {} DOMAIN. | 10 | 86400

    Template Google Apps:
    A|{DOMAIN}.|{IP}|0|86400
    A|www|{IP}|0|86400
    CNAME|mail|ghs.google.com.|0|14400
    CNAME|docs|ghs.google.com.|0|14400
    CNAME|agenda|ghs.google.com.|0|14400
    NS|{DOMAIN}.|ns1.vidit.com.br.|0|14400
    NS|{DOMAIN}.|ns2.vidit.com.br.|0|14400
    NS|{DOMAIN}.|ns3.vidit.com.br.|0|14400
    MX|{DOMAIN}.|aspmx.l.google.com.|10|14400
    MX|{DOMAIN}.|alt1.aspmx.l.google.com.|20|14400
    MX|{DOMAIN}.|alt2.aspmx.l.google.com.|20|14400
    MX|{DOMAIN}.|aspmx2.googlemail.com.|30|14400
    MX|{DOMAIN}.|aspmx3.googlemail.com.|30|14400
    MX|{DOMAIN}.|aspmx4.googlemail.com.|30|14400
    MX|{DOMAIN}.|aspmx5.googlemail.com.|30|14400
    TXT|"v=spf1 include:_spf.{DOMAIN} include:_spf.google.com ~all"|14400

    And use these settings to get the message example below:
    dns_master_load: /etc/bind/pri.almeidasports.com:10: syntax error
    zone almeidasports.com/IN: loading from master file /etc/bind/pri.almeidasports.com failed: syntax error
    zone almeidasports.com/IN: not loaded due to errors.
    _default/almeidasports.com/IN: syntax error

    What am I doing wrong and how to configure? as much help and templates setup.
     
  2. till

    till Super Moderator

    They are not correct, as there is no such placeholder {}. I guess you mean {DOMAIN}. instead? and chars inside of curly brakes have to be all uppercase. All valid placeholders are used in the default template, please see it as an example for a working dns template.
     

Share This Page