How to configure a website

Discussion in 'Installation/Configuration' started by DualFusion, Dec 9, 2007.

  1. DualFusion

    DualFusion New Member

    Ok, I installed ISPConfig with The Perfect Setup - Ubuntu Gutsy Gibbon (7.10). Now the next step is to know how to configure a website in it and displaying it properly on the internet. Currently, I tried to set it up and i see the Document Root directory ("/") file list. I doubt I am not supposed to see that, I am supposed to be seeing the site in "/www.synarchydesign.com/web/". I would like to know how to create the zones, plans, records, and every possible thing to do.

    I also have another problem: For some reason only I can see this problem. Others see a "Server not found" error. What would be the problem. In all the configurations I have done, I have put my external IP (75.74.102.247) instead of my internal IP (192.168.1.4). I have port forwarding enabled in my router with http, ftp, ispconfig, dns, and all the others in the Firewall tab of ISPConfig pointing towards 192.168.1.4. What could be the problem for this?

    Thanks! :)

    EDIT: My website is http://synarchydesign.com and I wanted to know how i can get the www. part working. I checked the ports in the router AND in ISPConfig, and are open. I have TelNet working on TCP port 23, is that alright?
     
    Last edited: Dec 9, 2007
  2. Hans

    Hans Moderator ISPConfig Developer

    Reading the manuals on http://www.ispconfig.org/documentation.htm is a good starting point. :)

    If your server is behind a router within a LAN, your ISPConfig server should have the internal IP-address 192.168.1.4.
    Within your router you need to set portforwarding from your public IP-address 75.74.102.247 to your internal IP-address 192.168.1.4.

    Ports to be forwarded are:

    FTP, PORT 21
    SSH, PORT 22
    HTTP, PORT 80
    ISPCONFIG, PORT 81
    HTTPS, PORT 443
    SMTP, PORT 25
    POP, PORT 110
    IMAP, PORT 143
    DNS, 53

    Port 23 for Telnet is ok, but I advise you to use SSH, not Telnet as it is more secure. For using SSH, you need to open/forward port 22.
    To setup a SSH-connection to from any local desktop to your server, you can use a program like Putty, which can be downloaded here: http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html

    Your whole directory is displayed and that's not ok.
    Can you publish the content of your file /etc/apache2/vhosts/Vhosts_ispconfig.conf ?
     
    Last edited: Dec 9, 2007
  3. DualFusion

    DualFusion New Member

    I had originally had both telnet AND ssh open. I have checked all my ports again in ISPConfig and my router configuration manager, and all the necessary ports are open. I have read the documentation, yet when I try to implement these, i still can not get my site available to the public. Also, I do not understand which IP's I have to put where. Here is my vHost file:
    Code:
    ###################################
    #
    # ISPConfig vHost Configuration File
    #         Version 1.0
    #
    ###################################
    #
    NameVirtualHost 75.74.102.247:80
    <VirtualHost 75.74.102.247:80>
      ServerName localhost
      ServerAdmin [email protected]
      DocumentRoot /var/www/sharedip
    </VirtualHost>
    #
    #
    ######################################
    # Vhost: www.synarchydesign.com:80
    ######################################
    #
    #
    <VirtualHost 75.74.102.247:80>
    ServerName www.synarchydesign.com:80
    ServerAdmin [email protected]
    DocumentRoot /var/www/web1/web
    ServerAlias synarchydesign.com www.synarchydesign.com
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ScriptAlias  /cgi-bin/ /var/www/web1/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /var/www/web1/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php3>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php4>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php5>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode On
    php_admin_value open_basedir /var/www/web1/
    php_admin_value file_uploads 1
    php_admin_value upload_tmp_dir /var/www/web1/phptmp/
    php_admin_value session.save_path /var/www/web1/phptmp/
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    AddType application/vnd.wap.wmlscriptc .wmlsc .wsc
    AddType text/vnd.wap.wml .wml
    AddType text/vnd.wap.wmlscript .ws .wmlscript
    AddType image/vnd.wap.wbmp .wbmp
    Alias /error/ "/var/www/web1/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
    </VirtualHost>
    #
    #
    #
    Thanks!
     
  4. Hans

    Hans Moderator ISPConfig Developer

    Within your vhost file i see that the external public IP-address has been used, while your server is behind a router. So this is not correct.

    You can correct this by changing the server IP-address within ISPConfig under Management > Server > Settings > IP Address: 192.168.1.4.

    Dont forget to press "save" after changing the IP-address.
     
  5. wpwood3

    wpwood3 New Member

    The first thing you need to do is setup your nameservers.
    When i dig synarchydesign.com this is the result:

    Code:
     
    ; <<>> DiG 9.3.3rc2 <<>> synarchydesign.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 22710
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 1
    ;; QUESTION SECTION:
    ;synarchydesign.com.            IN      A
    ;; ANSWER SECTION:
    synarchydesign.com.     86400   IN      A       75.74.102.247
    ;; AUTHORITY SECTION:
    [COLOR=red]synarchydesign.com.     86400   IN      NS      [/COLOR][URL="http://www.synarchydesign.com/"][COLOR=red]www.synarchydesign.com[/COLOR][/URL][COLOR=red].
    synarchydesign.com.     86400   IN      NS      df1.synarchydesign.com.[/COLOR]
    ;; ADDITIONAL SECTION:
    [URL="http://www.synarchydesign.com/"]www.synarchydesign.com[/URL]. 86400   IN      A       75.74.102.247
    ;; Query time: 414 msec
    ;; SERVER: 66.151.174.70#53(66.151.174.70)
    ;; WHEN: Sun Dec  9 16:21:42 2007
    ;; MSG SIZE  rcvd: 104
     
    
    The information in red above is incorrect. Nobody can find your site because the nameservers are incorrect.

    You must use valid nameservers that are setup at your domain registrar. That would be Network Solutions, GoDaddy, etc. This is not something you can do on your server.

    Something like:
    ns1.synarchydesign.com
    ns2.synarchydesign.com

    Those nameservers must point to the IP address of your server and you must list the nameservers in ISPConfig.

    If you search this forum you will find lots of info regarding DNS and nameservers. Does your servers have more than one IP address? If so, the 2 nameservers should point to different addresses on your server. If your server only has one IP address it requires a little more work when you setup the nameservers at your registrar.


    Also, use your INTERNAL IP address in ISP Manager and your EXTERNAL IP address in DNS Manager.
     
    Last edited: Dec 9, 2007
  6. DualFusion

    DualFusion New Member

    Thanks to you both! Its now working :D
     
  7. wpwood3

    wpwood3 New Member

    Yep, it appears so.

    Life is good!
     

Share This Page