How to config spamassassin and clamAV in ISPconfig?

Discussion in 'Installation/Configuration' started by tom, Apr 20, 2006.

  1. tom

    tom Member

    I loose mails with this "mail-test-content":
    X5O!P%@AP[4\PZX54(P^)7CC)7}$EICAR-STANDARD-ANTIVIRUS-TEST-FILE!$H+H*

    I get mails without spam or viruses but within spam or viruses the mails are gone.
    I think that's the default configuration - but I don't want them deleted.

    How can I config the behavior of spamassassin and clamAV in ISPconfig?

    tom
     
  2. till

    till Super Moderator

    X5O!
    Is the eicar antivirus test pattern. Emails with this pattern are treated as virus and where removed.

    You can configure the spamassassin settings on the spam & antivirus tab of the mailuser.

    The virus scanner laways deletes the mail.
     
  3. tom

    tom Member

    Do you mean in the ISPConfig surface?

    tom
     
  4. till

    till Super Moderator

    Yes, in the settings of each email user.
     
  5. tom

    tom Member

    I only can find settings for
    but no settings to change the behavior from delete mails with spam or virus to not delete mails with spam or virus

    tom
     
  6. falko

    falko Super Moderator

    Under "Spam Strategie" you can select if you want spam to be deleted or to be delivered. But you cannot change the behaviour of the virus scanner. If you enable it for an account, it will always delete virus mails.
     
  7. tom

    tom Member

    Ok, but I would like to configure the behaviour of the virus scanner as well. It's not very nice to send an mail to sombody, no idea about sending a virus and the recipient is'nt informed about, that somebody was sending a mail to him.

    How it's possibly to configure clamAV not to delete a mail including a virus?

    tom
     
  8. falko

    falko Super Moderator

    You must then change the .antivirus.rc procmail script in the user's home directory and the template file /root/ispconfig/isp/conf/antivirus.rc_master.
     
  9. tom

    tom Member

    Maybe there is already a solution for that question - I hope so - somthing that sends virus-mails not to /dev/null but to suspected virus.

    tom
     
  10. falko

    falko Super Moderator

  11. deezone

    deezone New Member

    Cannot see spam & antivirus tab

    under the mailuser login you can only see:

    User & Email
    Autoresponder
    Forwarder
    Language

    --Same is true when you open the ISP user details only the
    User & Email and Advanced Settings tab is available.

    Any idea what went wrong?
     
  12. till

    till Super Moderator

    The spamfilter configuration is not available in the mailuser interface if I remember correctly.

    In the User settings in the ISP-Manager is an "Spamfiletr and Antivirus" tab. Have a look at the online demo:

    http://www.ispconfig.org/demo.htm
     
  13. deezone

    deezone New Member

    Ok, in the ISP User settings there's no Spamfilter and Antivirus Tab, I can only see the following:

    -Usert & Email Tab
    -Advanced Tab.
     
  14. falko

    falko Super Moderator

    When you edit or create a user in ISPConfig, you have the following tabs:
    - User & Email
    - Advanced Settings
    - Spamfilter & Antivirus
     
  15. deezone

    deezone New Member


    Yes I went exact to what you are describinging but I can only see two tabs: User & Email and Advances Settings. I'm logged on as the admin user and still the tab is not there. I thought an upgrade from an earlier version to Ver 2.2.2 would fix it but it didn't.

    I looked at my other ISPConfig (test) server and that has all 3 of the tabs you are saying but on my ISPConfig (live) server the Spamfilter & Antivisrus TAB is not there.
     
  16. falko

    falko Super Moderator

    You must enable Spamfilter under Management -> Server -> Settings -> Email.
     
  17. deezone

    deezone New Member

    Cool! Thanks a lot falko!
     

Share This Page