How to config kdb to debug kernel 2.6.24

Discussion in 'Kernel Questions' started by ngocct, Dec 22, 2008.

  1. ngocct

    ngocct New Member

    Hello all !

    I want to patch the kdb (Build-in Kernel Debugger) to my kernel (packet 2.6.24) for debugging. I performed:

    1. Make directory linux-source at /home/ngocct and extract packet linux source 2.6.24 to this directory.
    mkdir linux-source/
    tar jxvf linux-source-2.6.24.tar.bz2 -C /home/ngocct/linux-source
    2. change to linux-source directory then patch two kdb patches to kernel source.
    patch -p1 < /home/ngocct/patch/kdb-v4.4-2.6.24-common-2
    patch -p1 < /home/ngocct/patch/kdb-v4.4-2.6.24-x86-2

    no error or warming to reported.

    3. config
    make menuconfig
    // then I load my old config and change:
    Setting this also sets CONFIG_KALLSYMS=y.
    KDB may be extended, compiling kdb/modules.
    // save to -> .config

    4. Buil kernel
    make-kpkg clean
    fakeroot make-kpkg --initrd --append-to-version=-custom kernel_image kernel_headers

    5. Install The New Kernel
    dpkg -i linux-image-
    dpkg -i linux-headers-

    // ok and in /boot/gru/menu.lst I saw:
    title Ubuntu 8.04.1, kernel
    root (hd0,2)
    kernel /boot/vmlinuz- root=UUID=1544a9fa-0c0d-4ba8-9903-db7e892e2b77 ro quiet splash
    initrd /boot/initrd.img-

    title Ubuntu 8.04.1, kernel (recovery mode)
    root (hd0,2)
    kernel /boot/vmlinuz- root=UUID=1544a9fa-0c0d-4ba8-9903-db7e892e2b77 ro single
    initrd /boot/initrd.img-

    6. Reboot

    sudo reboot

    7. Problem

    apter reboot I check the kdb status ( in user-mode).
    cat /proc/sys/kernel/kdb
    // screen :
    I login as root then invoke the kdb by press Pause on keyboard, but the kdb don't invoke. The system is halted and two lamp Caps Lock and Scroll Lock is blinking. I must hard reset.

    Please help me to fix this problem and can debugging my kernel by kdb.

    Thank a lot !
    Last edited: Dec 23, 2008
  2. falko

    falko Super Moderator ISPConfig Developer

    Any errors in your logs or in the output of
  3. snayak1

    snayak1 New Member

    I am also facing similar problem as described above.

    Can anyone please help me out ??

Share This Page