How to completely uninstall ISPConfig?

Discussion in 'Installation/Configuration' started by Dan Thurman, Dec 15, 2007.

  1. Dan Thurman

    Dan Thurman New Member


    I have: /root/ispconfig/uninstall to uninstall ISPConfig and yet I still have the GDM/Gnome gdmgreeter hang problem after rebooting.

    This means that ISPConfig is not completely removed and it has not restored my system state prior to the installation of ISPConfig.

    Can someone please advise how I can *completely* remove ISPConfig so that my GDM/Gnome greeter works again?

  2. falko

    falko Super Moderator ISPConfig Developer

    ISPConfig is completely removed. I don't know why there's this GDM problem on Fedora... :confused:
  3. Dan Thurman

    Dan Thurman New Member

    I responded to another thread that discusses how to get ISPConfig to work with Fedora by creating the /etc/sysconfig/desktop file and to use KDE to get it working. I had basically explained that you might be able to get GDM working by choosing a different GraphicalTheme other than FedoraInfinity in /usr/share/gdm/default.conf, and may not need to create the /etc/sysconfig/desktop file.

    It is clear to me that installing ISPConfig *does* affect Fedora 7/8's GDM probably indirectly by changing something in the system files (quite possibly the passwd, group, shadow files) that prevents the FedoraInfinity theme from working correctly, or so it seems.
  4. Dan Thurman

    Dan Thurman New Member

    It was discovered that /etc/shells had the following entry:

    added to the end of this file and this caused havoc to many programs since python's function: libuser.get_user_shells() in module: libuser does not check if each shell in this list exists or is functional and so causes certain programs such as GDM, setroubleshootd and sealert to fail or hang.

    Removing the /SENDMAIL/ANY/SHELL item from /etc/shells will allow GDM, and other programs that uses that python function to work.

    I suspect that either sendmail, postfix, or possibly ISPConfig has added that line item in /etc/shells after installation but I am not sure which one of these applications made this change.

    Please disregard my previous comments in changing the /usr/share/gdm/default.conf GraphicalThemes default settings found there.

  5. popacio

    popacio New Member

    well i don't get it!
    what can I do besides reinstalling Fedora if i cannot login to remove that line.

    can anyone tell me EXACLTY what to do.
  6. falko

    falko Super Moderator ISPConfig Developer

    Open /etc/shells and remove the /SENDMAIL/ANY/SHELL line from it.
  7. jkrell

    jkrell New Member

    Thanks a Mill...

    ...this worked for me after I experienced the same problem and freaked out when my Fedora system would not allow me to log in. These forums really rock and thanks to you all.

    One thing I noticed, in the login screen, I now have an "ISPConfig Administrator" listed as a user. I wonder if this is because I changed the admin password within ISPConfig?? Anyway, all works now so thanks again.
  8. jkrell

    jkrell New Member

    Falko, do you think it would be safe to delete that user account?
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    If you uninstalled ISPConfig, you can delete this user. If you still use ISPConfig, you will break ISPConfig by deleting the user.
  10. jkrell

    jkrell New Member

    Thanks, I'll still be using ISPConfig, so I guess I will let it be.
  11. lucius

    lucius New Member

    uninstall does not work

    I have gone to the uninstall prog in /root/ispconfig which will not execute as any user including root, I have chmoded the file a few times to see if that change things but no joy. What am I doing wrong?
  12. sergio.morales

    sergio.morales New Member

    You guys ROCK!!

    Thanks! It fixed my issue!! I have to be honest, I thought this "Linux thing" was a big sham, with all it's Open Source, but the fact that you can get answers like this on a very short time span has made me a believer!
    I'm going out tomorrow and getting a Penguin Tattoo tomorrow!!!

    Thanks all!

  13. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    ls -la /root/ispconfig/uninstall
  14. dennis.wolf

    dennis.wolf New Member

    It works well!

    Thank you very much! It saves my life.

    After my installation, I Delete /SENDMAIL/ANY/SHELL directly from file /etc/shells.
    Then everything works fine!
  15. vaio1

    vaio1 ISPConfig Developer ISPConfig Developer

    The ISPCONFIG doesn't start!

    Hi guys,

    I need some help to restore the ISPCONFIG. After a reboot, when I write in the browser the system doesn't start. The web interface of ISPCONFIG isn't shown.

    Any suggestion is appreciated.
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    Please run:

    /etc/init.d/ispconfig_server restart
  17. vaio1

    vaio1 ISPConfig Developer ISPConfig Developer

  18. tristanlee85

    tristanlee85 New Member

    This is great. I formatted my system 4 times going from FC9 to FC8 to FC9 then reinstalling FC9 to figure out the issue. I thought it was happening when I installed ColdFusion, but I guess not. Thanks a ton!
  19. diocassius

    diocassius New Member

    Omg - thank you!!!


    I just wanted to say THANK YOU in a big way for this thread! I've been chasing this bug for two weeks on two different machines. I want to say that this fix not only works in Fedora 7, it also works in 10.

    I had myself convinced for a while this was a hardware issue with Radeon-based video cards.

    I know...

    I'm a total noob for wanting to use a GUI with a machine set up to be a server, but hey...


    I'll run my servers headless ninety percent of the time, using software like ISPConfig (wonderful program, Falko, I can never thank you enough for it, and your wicked cool tutorials) and WebMin to administrate them, but there are times I like to plug in a monitor, mouse, and keyboard and see a Gnome GUI staring back at me. I occasionally like to use GEdit, on the fly, on the server to make quick changes to scripts I have running on the web.

    Suffice to say, HowToForge makes my life a LOT easier... :)

    Now, if Falko could just write a tutorial on how to explain to my girlfriend why I spend so much time messing with this stuff, I'd be all set! :)

    Thanks again!


Share This Page