how to compile php5.1.6 with gd and with jpg support?

Discussion in 'Programming/Scripts' started by tom, Oct 10, 2006.

  1. tom

    tom Member

    I've tried to compile php5.1.6 according to:
    But phpinfo() only shows that:
    The jpg-libs seems to be there.
    I don't know what's missing.
  2. falko

    falko Super Moderator ISPConfig Developer

    Any warnings in the ./configure output?

    Is that phpinfo() output from the correct PHP? Did you restart Apache?
  3. tom

    tom Member

    ok, I've found a solution by giving more details to confingure (but I don't understand why the configure-script did not find the libs because they aren't in an unusual path.)
    --with-jpeg-dir=/usr/lib --with-png-dir=/usr/lib

    And now:
    GD Support enabled
    GD Version bundled (2.0.28 compatible)
    GIF Read Support enabled
    GIF Create Support enabled
    JPG Support enabled:)
    PNG Support enabled
    WBMP Support enabled
    XBM Support enabled
  4. Torsten72

    Torsten72 New Member

    how did you locate the right dir

    Thanks Torsten
  5. falko

    falko Super Moderator ISPConfig Developer

    You could run
    locate png
    locate jpeg
    to find out what the right directory might be.

Share This Page