How To Compile A Kernel - The SuSE Way

Discussion in 'HOWTO-Related Questions' started by timbelina, Dec 29, 2006.

  1. timbelina

    timbelina New Member

    'afternoon Falko,

    First up, thanks for your article, which I read at:

    http://www.howtoforge.com/kernel_compilation_suse

    The article was very clear and easy to follow. However, I had two quick
    questions for you, if you have a moment.

    My setup is a SuSE 10.0 2.6.13-15-default kernel, running on an AMD64.
    I have actually tried SuSE 10.1, but I really disliked the changes that
    have been made to SaX; I am building MythTV boxes for friends'
    wide-screen TVs, and the 10.1 changes to SaX and make modifying
    xorg.conf quite difficult. Anyhow, that's irrelevant for now :)

    When I follow your article with my 10.0 setup, I end up with two
    questions:

    1) One of the first steps in your article is to modify the find-*kysyms
    tools. However, my distro does not have these tools! I have the various
    find*.pl and find* files in /usr/lib/rpm, but no *kysyms. So, I ignored
    this step, and everything seemed to go fine. Would you expect any
    hassles?

    2) The RPM build and install all worked fine. However, mkinitrd failed
    with a goofy error:
    Cannot determine dependencies of module sata_via.\
    Is modules.dep up to date?
    I have done a bit of Googling for this, but cannot seem to figure out
    how to fix it. The end result is that the sata drivers do not seem to
    be included in the kernel, since when I boot the new image, I end up
    with a failure waiting for device /dev/sda1 to appear. Would you have
    any ideas regarding getting modules.dep up to date?

    Thanks again,
    Tim.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    I wrote the tutorial on SuSE 10.1, so it's possible that this step doesn't have to be done on SuSE 10.0. :)

    What's in /etc/modules?
     

Share This Page