How to check if quota (email) is working?

Discussion in 'Installation/Configuration' started by jameztcc, Aug 19, 2010.

  1. jameztcc

    jameztcc New Member

    Hi,

    I installed based on the howto for centos 5.5 64bit using ispconfig3.

    I am trying to figure out where or how the quota is being set, not sure if it's working now.


    thanks,
    James Tan
     
  2. Polk

    Polk HowtoForge Supporter

    same with me. I think i followed all steps, but not sure if it was setup correctly.
    Can someone here help troubleshoot quota?
    How to check if it's running?
    How to test if it's blocking disk space correctly,etc?

    thanks
     
  3. Rapid2214

    Rapid2214 New Member

    If you have roundcube you can see the disk quota at the bottem of the page, if quota is not working, it will be messed up or N/A.

    Also you can see quota boot on startup.

    You can also use these commands (Ubuntu, but may work for others)
    Code:
    quotacheck -avugm
    quotaon -avug
    
    Marty
     
  4. jameztcc

    jameztcc New Member

    Hi,

    mine showed "unknown" on RC. Any way to troubleshoot this?

    thanks,
    James Tan
     
  5. Rapid2214

    Rapid2214 New Member

    Whats the out put of
    Code:
    quotacheck -avugm
    and

    Code:
    quotaon -avug
     
  6. Polk

    Polk HowtoForge Supporter

    Code:
    [root@nm01 ~]# quotacheck -avugm
    quotacheck: Can't find filesystem to check or filesystem not mounted with quota option.
    I'm on Centos5.5
     
  7. Rapid2214

    Rapid2214 New Member

    Ok, to see if quota is enabled, what is the options output on /?

    In /etc/fstab

    Code:
    nano /etc/fstab
     
  8. Polk

    Polk HowtoForge Supporter

    Code:
    /dev/VolGroup00/LogVol00 /                      ext3    defaults,usrquota,grpquota
    1 1
    LABEL=/boot             /boot                   ext3    defaults        1 2
    tmpfs                   /dev/shm                tmpfs   defaults        0 0
    devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
    sysfs                   /sys                    sysfs   defaults        0 0
    proc                    /proc                   proc    defaults        0 0
    /dev/VolGroup00/LogVol01 swap                   swap    defaults        0 0
    
     
  9. Rapid2214

    Rapid2214 New Member

    Sorry, i donno with CentOS, your'll have to wait till Falko makes a visit :D
     
  10. Polk

    Polk HowtoForge Supporter

    Yup. No problem. thanks for trying anyway :) I'll wait.
     
  11. falko

    falko Super Moderator

    Please reboot and then try
    Code:
    quotacheck -avugm
    and
    Code:
    quotaon -avug
    again.
     
  12. jameztcc

    jameztcc New Member

    Hi,

    I got this


    [root@xxx ~]# quotacheck -avugm
    quotacheck: Quota for users is enabled on mountpoint / so quotacheck might damage the file.
    Please turn quotas off or use -f to force checking.

    [root@xxx ~]# quotaon -avug
    quotaon: using //aquota.group on /dev/mapper/VolGroup00-LogVol00 [/]: Device or resource busy
    quotaon: using //aquota.user on /dev/mapper/VolGroup00-LogVol00 [/]: Device or resource busy

    thanks,
    James Tan
     
  13. falko

    falko Super Moderator

    Please try
    Code:
    quotaoff -avug
    quotaon -avug
     
  14. jameztcc

    jameztcc New Member

    Here's my output:

    Code:
    [root@xxx ~]# quotaoff -avug
    /dev/mapper/VolGroup00-LogVol00 [/]: group quotas turned off
    /dev/mapper/VolGroup00-LogVol00 [/]: user quotas turned off
    [root@xxx ~]# quotacheck -avugm
    quotacheck: Scanning /dev/mapper/VolGroup00-LogVol00 [/] done
    quotacheck: Checked 19657 directories and 163839 files
    [root@xxx ~]# quotaon -avug
    /dev/mapper/VolGroup00-LogVol00 [/]: group quotas turned on
    /dev/mapper/VolGroup00-LogVol00 [/]: user quotas turned on
    thanks,
    James Tan
     
  15. jameztcc

    jameztcc New Member

  16. falko

    falko Super Moderator

    That means it is working now. :)
     

Share This Page