How to change hostname and others in ISPconfig3.1.7?

Discussion in 'Installation/Configuration' started by DARK9Y8, Nov 28, 2017.

  1. DARK9Y8

    DARK9Y8 New Member

    Hello Team,
    I am using ISPConfig 3 since 4 months. I was using cloud.abc.com as my hostname. Now, I want change it and in all other services like postfix etc. My IP address is same.

    Current Domain: cloud.abc.com
    New Domain: panel.xyz.cloud
    ISPConfig Ver: 3.1.7p1 ( Apache Stack )
    OS: Debian 9

    Thank you
     
  2. ahrasis

    ahrasis Well-Known Member

    That should be covered in the minimal server tutorials somewhere at the last part.
     
    gilson likes this.
  3. gilson

    gilson New Member

    ISPConfig 3 Hostname Change, try try change in /etc/hosts and /etc/hostname, even deleting, it goes back again to:

    10.142.0.2 srv.us-east1-b.c.drarebecagomes-221302.internal srv # Added by Google
    169.254.169.254 metadata.google.internal # Added by Google


    I want run the command and stay that way hostname -f painel.drarebecagomes.com and not like
    srv.us-east1-b.c.drarebecagomes-221302.internal

    Can you help me? Thank
     
  4. ahrasis

    ahrasis Well-Known Member

    Which distro? What is the output of ls -l /etc/host*? What is the contents of your /etc/hosts and /etc/hostname?
     
    gilson likes this.
  5. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Do your changes to /etc/hosts get overwrittern or is it just adding that ip-number and hostname there automatically?
    If Google just adds those lines, put your line before or after them.
    Ask Google how /etc/hosts is supposed to work, maybe there is setting that prevents Google modifying it.
    Search engines find tricks to modify it back at every reboot.
     
  6. gilson

    gilson New Member

    My dear, Ahrasis, this below

    My Distro = Debian 9 stretch
    [email protected]:~$ sudo ls -l /etc/host*

    -rw-r--r-- 1 root root 9 ago 7 2006 /etc/host.conf
    -rw-r--r-- 1 root root 7 nov 3 20:26 /etc/hostname
    -rw-r--r-- 1 root root 222 nov 25 06:58 /etc/hosts
    -rw-r--r-- 1 root root 411 out 11 17:15 /etc/hosts.allow
    -rw-r--r-- 1 root root 711 out 11 17:15 /etc/hosts.deny

    Content of /etc/hosts
    127.0.0.1 localhost
    127.0.0.1 painel.drarebecagomes.com painel
    10.142.0.2 srv.us-east1-b.c.drarebecagomes-221302.internal srv # Added by Google
    169.254.169.254 metadata.google.internal # Added by Google

    Content of /etc/hostname
    painel


    I want when run the command hostname -f = appear = painel.drarebecagomes.com
    to after I configure the SSL in painel.drarebecagomes.com:8080






     
    Last edited: Nov 25, 2018
  7. ahrasis

    ahrasis Well-Known Member

  8. gilson

    gilson New Member

    I already asked for help to him, and I also did the procedure that he indicates, but does not work...
     
  9. gilson

    gilson New Member

    @ahrasis I do not understand how to add
    $ gcloud compute instances add-metadata <instance> --metadata hostname=<new_hostname>
    a like

    gcloud compute instances add-metadata <srv.us-east1-b.c.drarebecagomes-221302.internal> --metadata hostname=<painel.drarebecagomes.com>

    thanks

     
  10. ahrasis

    ahrasis Well-Known Member

Share This Page