How to allow ssh for single users?

Discussion in 'Installation/Configuration' started by bolero, Jun 10, 2010.

  1. bolero

    bolero New Member

    I think I remember there was an option to allow SSH access either for a user or for the web. I can't find it anymore. Searching the admin manual finds only one location where it talks about the general access for the admin. We removed some options from the form templates. Maybe we removed that option? (We normally don't allow SSH for clients.)
    So, is it correct that there normally is an option to enable this in the ISPConfig GUI or am I mistaken? If so, is there a way to easily add it to the form template again?
    Or can I do it manually in /etc/passwd without ISPConfig overwriting it next time something gets changed?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Enable the "ssh" checkbox in the settings of this user in ispconfig.

  3. bolero

    bolero New Member

    There is no such checkbox. That is why I'm asking if we may have removed it from the template (via the template designer) and if so how we can readd it.
  4. falko

    falko Super Moderator ISPConfig Developer


    I don't know what you changed.
  5. bolero

    bolero New Member

    Well, but you probably know what has to be there, so SSL can be enabled? ;-)
    I remember that we removed stuff from the templates ebcause we didn't want to have resellers hand out SSH logins. So, there has to be a section in the original template that includes the template code. Can you tell me which template that is and what the correct code might be? Or can you tell me in which table I can set this suer to have SSH and how to trigger that, so that ISPConfig carries it out to the responsible system files? Or can I just enable that user for SSH in /etc/passwd by giving him a real shell?
  6. bolero

    bolero New Member

    Resolved. I should have been able to fix this within a minute without posting here. Somehow, I overlooked the entry in the Forms Designer.

Share This Page