How to add co-domain's mailuser

Discussion in 'Installation/Configuration' started by citronz, Jan 24, 2008.

  1. citronz

    citronz New Member

    Setup looks like this:
    In Options all 4 domains have set to External mailserver.
    Everything works as it intened to be.

    Now I need to make some changes - anotherdomain.tld to be set to Local mailsererver but all others should stay the same. I can do it just by setting this different setup in options tab for anotherdomain.tld, but i guess there is no sense because I can't make users for this co-domain.

    I guess I can make just normal domain instead of co-domain, www forward it to accordant webdir and deal with emails seperatly. But I can't guess - have to be sure about it cause it is production server.

  2. Hans

    Hans Moderator ISPConfig Developer

  3. citronz

    citronz New Member

    It's getting interesting. I made mail user [email protected] and did
     telnet 110
    Connected to
    Escape character is '^]'.
    +OK Dovecot ready.
    USER [email protected]
    PASS 12345678
    -ERR Authentication failed.
    USER [email protected]
    PASS 12345678
    +OK Logged in.
    +OK Logging out.
    Connection closed by foreign host.
    As we can see - for main domain user is accepted. For co-domain - not.
    Maybe that is because I did modificitions with dovecot.conf for accepting mailusers as [email protected]? So Co-domains nomore working in this way? And so - the only way to do this is create co-domain as normal domain.

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig users do not contain a @ sign, please use the username of the mailbox and not the email address to authenticate with dovecot.
  5. citronz

    citronz New Member

    It's not realy the case :) Everything works fine with setup similar to this:

    I guess there just are some things I can't do (like setting co-domain email users) if I do such modification to dovecot.

Share This Page