How secure is to update ISP3?

Discussion in 'Installation/Configuration' started by DonAteloNow, Feb 21, 2009.

  1. DonAteloNow

    DonAteloNow New Member

    Hello, fellows,

    I would like to update my ISP3 RC1 to RC2, but i have more than 50 domains on it for now, so hopefully majority of yours can understand why I'm so affraid to "broke" something. I'm going to use ispconfig_update_from_svn.sh command for that. Nothing really special in installed next to RC1 additionally. Only RoundCube 0.2 stable, Zend Optimizer, phpMyAdmin 2.11, but those apps have nothing to do directly with ISP3, right? Also no modifications were done to RC1 files.
    Or would be better to wait for final version? I'm ready to pay for remote update as well, when final version appears if there could be some problems with updates.

    Thanks for all
     
  2. till

    till Super Moderator

  3. DonAteloNow

    DonAteloNow New Member

    Thanks, Till. That's what I did want to hear :)
     
  4. DonAteloNow

    DonAteloNow New Member

    htscanner.so

    I would like to confirm, that update went fine. Of course, after making some changes, that was suggested on reply above by Till.

    Anyway, I still have one little problem. In the file INSTALL_UBUNTU_8.04.txt I found instruction

    ###
    add to the end of the file:
    ###
    [htscanner]
    Extension = "htscanner.so"
    config_file = ".htaccess"
    default_docroot = "/var/www"
    ###

    After this, I'm getting error below:

    php -v

    PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20060613/htscanner.so' - /usr/lib/php5/20060613/htscanner.so: cannot open shared object file: No such file or directory in Unknown on line 0
    PHP 5.2.4-2ubuntu5.5 with Suhosin-Patch 0.9.6.2 (cli) (built: Feb 11 2009 20:09:11)
    Copyright (c) 1997-2007 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
    with Zend Extension Manager v1.2.2, Copyright (c) 2003-2007, by Zend Technologies
    with Zend Optimizer v3.3.3, Copyright (c) 1998-2007, by Zend Technologies

    I have not file htscanner.so in directory /usr/lib/php5/20060613/. Also, I can't to find it in whole system.

    So, is those lines necessary and if yes, where can I get htscanner.so file?

    Thanks!
     
  5. sefs

    sefs New Member

    I too just discovered this browsing thru the logs. How can this be fixed.

    Edit: I also found a version for feisty here https://launchpad.net/~malept/ archive/ppa, I am on hardy but i installed it anyway to see what the results will be.

    Thanks.
     
    Last edited: Mar 23, 2009
  6. till

    till Super Moderator

    htscanner is a php extension from your linux distribution and is not used by ispconfig. If the .so file is missing then you should remove the line that loads this extension from the php.ini files.
     
  7. ozzykiev

    ozzykiev New Member

    how can i update form ispconfig 3.0.0.9 to 3.0.1 ?

    how can i update form ispconfig 3.0.0.9 to 3.0.1 ? can ypu help me pls?
     
  8. till

    till Super Moderator

Share This Page