How my friend made phpmyadmin work

Discussion in 'Tips/Tricks/Mods' started by patrickfoley, Apr 23, 2009.

  1. patrickfoley

    patrickfoley New Member

    As some of you have already experienced, after you create a website (or host a domain) and then create a database, you cannot access the database thru phpmyadmin.

    When you click on the database icon within ispconfig3, the intended url is redirected and you get either an error or broken link.

    The solution my friend implemented was to create a link as follows:

    cd /var/www
    ln -s /usr/share/phpmyadmin phpmyadmin

    this is working for me.

    thanks to falko and till etc for all their help.
     
  2. Thomas Jensen

    Thomas Jensen New Member

    It worked for me too, but only from the main domain.

    Is it possible to make it work for each website? like: domain.com/phpmyadmin and domain2.com/phpmyadmin?

    It worked before i reinstalled ISPconfig.

    I think it's the same problem which bothers me when i try domain.com/webmail
     
    Last edited: Apr 29, 2009
  3. Horfic

    Horfic Member

    You have to do for every domain this:
    Code:
    cd /var/www/{your Domain without www.}/web/
    ln -s /var/www/phpmyadmin phpmyadmin
     
  4. Thomas Jensen

    Thomas Jensen New Member

    But last time i installed ISPconfig 3, it worked automatically!
     
  5. tio289

    tio289 Member

    yes, you not use ln. just add this line to apache.conf

    Alias /phpmyadmin /usr/share/phpmyadmin

    this can use for webmail too

    Alias /webmail /usr/share/squirrelmail
    Alias /horde /usr/share/horde
     
  6. vogelor

    vogelor ISPConfig Developer

    let me help you ;-)

    Hi,
    i am Oliver, the "programmer" of the phpmyadmin link inside ISPC3.

    if you click on such a link, i am looking for the SERVER, the database is running at (for example server #1). Then i am looking in the server-configuration for the "name", this server has (for example s001.muv-server.com). Then i create a link to the phpmyadmin at this server.

    means (for this example)

    http://s001.muv-server.com/phpmyadmin

    this means, you only have to "create" a working phpmyadmin under your server (NOT under EVERY doamain!).

    if your server is called s1.myserver.com than you need a pypmyadmin under s1.myserver.com -> thats all.

    by the way. If you are using SSL with ISPC3, you must have a ssl certificate for your server too -> httpS://s1.myserver.com

    if you have any more question->feel free to ask!

    Olli
     
  7. vogelor

    vogelor ISPConfig Developer


    NO - NOT FOR EVERY DOMAIN! FOR THE SERVER ONLY!!!! see my post below
     
  8. F4LLEN

    F4LLEN New Member

    Hi Olli, im relatively new to ISP Config, ive managed to fully install it and have working client sites, but i cant seem to get phpmyadmin or webmail working, all i gte is a not found. Are you able to give me a slightly more detailed explanation of how youve set it up to work, so i can go through how mine is setup and make the neccessary changes. im really not sure where i went wrong as i followed the Debian Perfect Server tutorial perfectly.

    Cheers
     
  9. cobro

    cobro New Member

    I get this error when i try to connect to phpmyadmin or webmail -->



    Forbidden

    You don't have permission to access /phpmyadmin on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the reques



    and webmail error -->



    Forbidden

    You don't have permission to access /webmail on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
     
  10. till

    till Super Moderator

    You can use this only with mod_php or cgi-php without suexec or fcgi-php without suexec. Thats why we did not implement something like that by default, it simply does not work with 50% of the possible settings.
     
  11. cobro

    cobro New Member

    so if i change from fcgi-php to mod_php or cgi-php

    then i can connect to phpmyadmin and webmail ?

    i did a fresh install and i have never been able to connect to this ?

    but i am willing to learn :)

    thank you for a great software
     
  12. rlischer

    rlischer HowtoForge Supporter

    I hate to ask, but what command do I run in centOS 5.3 to create this needed pointer to myserver.com/phpmyadmin ?

    Thanks
     
  13. cat

    cat New Member

    Ok that is good to know. However if it is possible for ISPConfig be programmed so that where a link is suitable one is automatically created, and where a link is not suitable a full phpmyadmin is automatically installed in the web root?
     
  14. gwiz

    gwiz New Member

    CGI & Suexec don't play nice together?

    I may be confused? But from how I understand your response "till."

    Could this be why those who followed this How Two http://www.howtoforge.com/perfect-server-debian-lenny-ispconfig3

    May be having problems, or have the issues been fixed in updated releases?

    From your response CGI & Suexec don't play nice together, yet step "11" installs all.

    11 Install Apache2, PHP5, phpMyAdmin, FCGI, suExec, Pear, And mcrypt

    Apache2, PHP5, phpMyAdmin, FCGI, suExec, Pear, and mcrypt can be installed as follows:

    apt-get install apache2 apache2.2-common apache2-doc apache2-mpm-prefork apache2-utils libexpat1 ssl-cert libapache2-mod-php5 php5 php5-common php5-gd php5-mysql php5-imap phpmyadmin php5-cli php5-cgi libapache2-mod-fcgid apache2-suexec php-pear php-auth php5-mcrypt mcrypt php5-imagick imagemagick libapache2-mod-suphp
     
  15. till

    till Super Moderator

    There is nothing that can be fixed. The apache webserver is at it is and I will not write you a new webserver software ;)

    I explained in many threads, if you want a phpmyadmin installation without the limits that apache and the pacakges from your linux distribution have (and not ISPConfig, so it can not be fixed in ispconfig!), then create a new website like phpmyadmin.yourdomain.com and install a copy of phpmyadmin in this site
     
  16. gwiz

    gwiz New Member

    GET a LIFE till

    Did I ask you to write a NEW PROGRAM

    Idea behind a forum is to discuss things, or for people that don't understand - TO GET HELP.

    In reading through all your replies -- You "TILL" seem very ignorant, and short tempered to all criticism.

    You can take ISPConfig* and shove it where the sun don't shine for all I care.

    Falko on the other hand - Seems very knowledgeable and eager to help.

    May he be successful in his endeavors of creating a "Super System"

    GOOD DAY
     
  17. till

    till Super Moderator

    You are right, my answer was a bit harsh. I explained this already so many times in the forums. The problem is a permission problem as the phpmyadmin packages of the linux distributions were made for single server use and not for hosting systems were you have to access them from a bunch of vhosts.

    So if you need a phpmyadmin that is accessible from everywhere, you have to create a new website for it and install phpmyadmin into this website.
     
  18. gwiz

    gwiz New Member

    Sorry I Asked ....

    I understand your frustration of having to explain something over and over again.

    Nothing worse than beating the same subject to death


    However, I have only discovered ISPConfig a couple weeks ago, and just recently found the HowtoForge Website looking for answers.

    Sorry I decided to ask a few questions to clear up some confusions I have encountered.

    Maybe some of the How-Two articles should be more clear that phpadmin has problems with ISPConfig,

    Then your Forums wouldn't get flooded with DUMMIES like me asking the same questions.

    Good Luck with your project - With the communities (regulars) help you may achieve your goals one day.
     
  19. Thomas Jensen

    Thomas Jensen New Member

    Hi,

    I haven't installed any extra PHPmyadmin installations or similar, and I've managed to get /phpmyadmin and /webmail to work in ALL PHP modes.
    I think i just made some symlinks or/and some rewrites in the apache config files...

    Dont really know if it helps anything, but it is possible to get it to work.
     
  20. rukus77

    rukus77 New Member

    For what it's worth, I followed the CentOS 5.2 Perfect Setup w/ ISPConfig 3 and I can access phpmyadmin and webmail from every site I've created so far.

    I currently have 8 domains hosted and none exhibit this issue. I have not made any config changes either.

    Thanks,
    Mike
     

Share This Page