How eliminate the "SHELL='/usr/sbin/jk_chrootsh'" in cron files?

Discussion in 'Installation/Configuration' started by gsc-frank, Jul 17, 2013.

  1. gsc-frank

    gsc-frank New Member

    Hi all,

    My cron jobs work great if I add them with the prefix http://

    If I add the same cron job without the the http:// prefix it don't get execute. The script that I want run is a .php. Without the http:// prefix the file /etc/cron.d/ispc_chrooted_web3 have the following line:

    HTML:
    SHELL='/usr/sbin/jk_chrootsh'
    How can I avoid ISPConfig generate that line? I'm using the admin account to create the sites and don't found any option about

    Thanks
    Frank
     
  2. Croydon

    Croydon HowtoForge Supporter

    It is automatically added if the client has "chrooted" cron jobs in the limits.
    If you want to run jobs that are not chrooted you have to set to "full" in his limits.
     
  3. gsc-frank

    gsc-frank New Member

    Thanks for your quick reply Croydon!

    I used the admin ISPConfig user to create the cron jobs. I know that one can set "Max. type of cron jobs" per user, but what about the admin user? I can't see in the UI a place to specify "Full" as "Max. type of cron jobs" for the admin user.

    Thanks again
    Frank
     
  4. Croydon

    Croydon HowtoForge Supporter

    That is not possible. The mode of cron jobs depends on the client's rights, even when created by admin.
     
  5. gsc-frank

    gsc-frank New Member

    I don't associated the site neither my cron jobs to any client. I just have one ISPConfig account: admin. I don't need more account in my deployment, so I use admin account for everything.

    You can test easily what I said, just create a site with the admin account, then add a cron job again with the admin account and take a look in the /etc/cron.d or in the cron table of the ISPConfig database.

    Thanks again!
     
  6. Croydon

    Croydon HowtoForge Supporter

    Ok, houston we have a problem ;)

    The limit for cron jobs is taken from the client limits and default to "chrooted cron". If you have no client to attach the cron job to, you cannot override this setting.
    I think this could be added either as bug or feature request (honestly I'm not sure if it really is a bug) to the bugtracker.

    Anyway - I don't think It is intendet to use ISPConfig without creating at least one client for your own needs... Creating everything as admin without setting a client is quite unusual imho.
     
  7. gsc-frank

    gsc-frank New Member

    Thanks for your help.

    I filled a bug report here http://bugtracker.ispconfig.org/index.php?do=details&task_id=3048

    I think that this is a bug, cos if the admin user can create cron jobs without associate them to any user, its default value must be Full, after all, it is the admin right?

    The other way to solve this thing is disable unassociated cron jobs creation from the admin account to avoid confusions and user lost of time, but I think that is better change the default.

    Best Regards
     
  8. gsc-frank

    gsc-frank New Member

    Croydon,

    Seem to me that you know where is the code that set such default value. Could you pls pointing me there?

    The problem is that I have several sites created with the admin account. Seem to me easier change that default value and remember the change when update ISPConfig. The other options is create another user en each instance of the ISPConfig I have and then assign all sites to that user, but I'm afraid that such user change affect the site (file permissions, directory location... )

    Thanks for your support!
     
  9. Croydon

    Croydon HowtoForge Supporter

    Hm, I'm a bit puzzled at the moment.
    The lines are at interface/web/sites/cron_edit.inc.php starting at line 117.

    But from what I see in the code it should be "full" cron when created by admin without assigning a client.
     
  10. gsc-frank

    gsc-frank New Member

  11. till

    till Super Moderator

    Yes, this has been fixed in svn stable branch and will be released in 3.0.5.3.
     

Share This Page