How does ISPConfig 3.0.3 enable WebDav?

Discussion in 'Installation/Configuration' started by ferrao, Oct 12, 2010.

  1. ferrao

    ferrao New Member

    Don't seem to be able to make webdav work.
    Looking at my virtual domain config, all i see is :

    <IfModule mod_dav_fs.c>
    # DO NOT REMOVE THE COMMENTS!
    # IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
    # WEBDAV BEGIN
    # WEBDAV END
    </IfModule>

    But nothing really enables webdav on the server.

    I have read the manual, which i bought as soon as it was available, but have to say i am a bit disappointed. It does run you through virtually every single menu option and from a simple user perspective, it looks ok.

    But it does not tell you how things work under the hood, which is what i was looking for. Maybe the opportunity for something like a "Developer's manual" or advanced user?

    Anyway, i am going off topic here.

    Apart from not being able to enable dav, something else is not working.
    Manual says :

    Directory: This defines the subdirectory of your document root that you want to access with WebDAV. If you leave it empty, you can access the whole document root and its subdirectories with the WebDAV URL http://example.com:80/webdav. If you type in a subdirectory, e.g. images, you can access the images subdirectory as follows: http://example.com:80/webdav/images.

    But i i try it i (its exactly what i want), i just get :

    "Directory empty"
     
  2. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    The code above is fine, as ist the stub where the webdav rules get inserted when you add a new webdav user. Go to the webiste module and add a webdav user now. If you added a webdav user before the above lines got inserted into the vhost, it will not work and you have to delete the webdav user and add it again.
     
  3. ferrao

    ferrao New Member

    Actually i got the dav config in now..
    The problem was that i messed up the user prefix ([CLIENTNAME]) and ISPConfig did not liked it and as such, did not inserted this.

    I still can not access it.. This is what shows up in there :

    <IfModule mod_dav_fs.c>
    # DO NOT REMOVE THE COMMENTS!
    # IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
    # WEBDAV BEGIN

    Alias /root /var/www/clients/client6/web58/webdav/root
    <Location /root>
    DAV On
    AuthType Digest
    AuthName "root"
    AuthUserFile /var/www/clients/client6/web58/webdav/root.htdigest
    Require valid-user
    Options +Indexes
    Order allow,deny
    Allow from all
    </Location>
    # WEBDAV END
    </IfModule>

    root is what i used as my top user folder, because i could not leave the directory field empty (read previous).

    I have tried to auth with the properusername prefix+username but no success. Nothing shows up on this vdomain apache error log.

    Furthermore, after setting up a user, i seem to be unable to change it's directory. Is that normal?
     
  4. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    Which Webdav client do you use? The internal Windows 7 client is sometimes a bit tricky in conjunction with apache mod_dav.

    Yes, thats intended.
     
  5. DKLeader

    DKLeader New Member

    I got some of the same problems.
    Tried on a windows7 and on windows vista 64 bit.

    Also got the problem with
    if the field Directory is left only with the webdav/

    And as Ferrao wrote :
     
  6. ferrao

    ferrao New Member

    I use Mac OS X Finder to mount the WebDav shares.
    I have other webdav virtual domains that i had setup previously to webdav support in 3.0.3 and i have no problem with those.

     
  7. ferrao

    ferrao New Member

    In that case, the user manual is wrong.
    Can we open bugs on the user manual as well?

     
  8. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    With document-root the manual means the "webdav" directory here and not the "web" directory, as webdav support is mainly for document sharing and not access the "web" directory as the webdav user would have wrong permisions for that. But I see that this is indeed misleading in the manual and we will fix that for the next release of the manual.
     
  9. ferrao

    ferrao New Member

    The document-root being webdav or web is irrelevant for my point and for what i am trying to achieve for that matter.

    The manual clearly states "If you leave it empty", which the interface does NOT allow you to do.

    So i still believe something is wrong, either with the interface or with the manual.

     
  10. ferrao

    ferrao New Member

    The configuration that i have that works is :

    <Directory> /var/www/clients/client6/web48/web/webdav>
    Options +Indexes +MultiViews
    IndexOptions FancyIndexing
    AddDefaultCharset UTF-8

    DAV On
    AuthType Basic
    AuthName "webdav"
    AuthUserFile /var/www/clients/client6/web48/web/auth/passwd.dav
    Require valid-user
    </Directory>

    The configuration that ISPConfig automatically generates when i insert a new webdav user is :

    Alias /root /var/www/clients/client6/web58/webdav/root
    <Location /root>
    DAV On
    AuthType Digest
    AuthName "root"
    AuthUserFile /var/www/clients/client6/web58/webdav/root.htdigest
    Require valid-user
    Options +Indexes
    Order allow,deny
    Allow from all
    </Location>

    As i said, nothing gets printed in the error log, only access log bellow :

    85.247.213.127 - - [13/Oct/2010:00:28:14 +0100] "OPTIONS / HTTP/1.1" 200 0 "-" "WebDAVLib/1.1"
    85.247.213.127 - - [13/Oct/2010:00:29:22 +0100] "OPTIONS / HTTP/1.1" 200 0 "-" "WebDAVLib/1.1"
    85.247.213.127 - - [13/Oct/2010:00:29:22 +0100] "OPTIONS / HTTP/1.1" 200 0 "-" "WebDAVFS/1.8 (01808000) Darwin/10.4.0 (i386)"



     
  11. ferrao

    ferrao New Member

    Got it working finally!

    To summarize,

    1) You can not eliminate the user prefix from System/Interface Config, it will not work.
    2) Contrary to what the user manual says, you HAVE to specify a directory.
    3) You need to mount the volume with the URL <your_virtual_host>/<directory>
     
  12. gertjan

    gertjan New Member

    Access webfiles

    I would like to use webdav for accessing my html-files and scripts, not for other storage. Is that an option?

    Would this tutorial work:
    http://www.howtoforge.com/using-webdav-with-ispconfig-3-on-ubuntu-9.10

    Should I need to change the group of the website from "client1" to "apache" for this to work? And would that give any problems?
     
  13. till

    till Super Moderator Howtoforge Staff HowtoForge Supporter ISPConfig Developer

    No. The reason for that is that apc runs unser the apache user and not the website user. So apc has no write permissions to the website directory.

    This would disable the security layer which separates the websites, so it is a security issue if you would do that. So this change is only an option for inhouse servers without a connection to the internet.
     
  14. gertjan

    gertjan New Member

    Ok, thanks! I think I'll use it on my homeserver then, thas is used for development, but not on our dedicated webserver (ftp should be good enough for that). Would be very nice if it could be implemented in ISPConfig though...
     

Share This Page