How do I restart SpamAssassin after config changes?

Discussion in 'Installation/Configuration' started by Xinil, Jun 14, 2007.

  1. Xinil

    Xinil New Member

    I'm making spam modifications to : /home/admispconfig/ispconfig/tools/spamassassin/etc/mail/spamassassin/local.cf

    After I've made these changes, how do I restart spamassassin so that I can see the effects? Restarting my server isn't a good solution. :/

    Also, how do I check what version of spamassassin I'm running?

    Thanks.
     
    Last edited: Jun 14, 2007
  2. Hans

    Hans Moderator ISPConfig Developer

    Restarting Spamassassin & version check

    On Debian Etch you can restart Spamassassin with:

    /etc/init.d/spamassassin restart

    You can check the Spamassassin version with:

    spamassassin -V

    The output will be somethink like:

    SpamAssassin version 3.1.7-deb
    running on Perl version 5.8.8
     
  3. Xinil

    Xinil New Member

    Thanks for the response Hans. Unfortunately though, none of those commands work under my CentOS 4.5 perfect setup install.

    Are there other commands I need to use for CentOS?
     
  4. Hans

    Hans Moderator ISPConfig Developer

    Ok then... probably it is someting like:

    /etc/init.d/spamd retstart

    I am not sure but maybe you can check the version with:

    spamd -V or -v
     
  5. Xinil

    Xinil New Member

    -bash: /etc/init.d/spamd: No such file or directory

    -bash: spamd: command not found

    :( Spamassassin is definitely installed too. I can accept/discard and change settings.
     
    Last edited: Jun 14, 2007
  6. Hans

    Hans Moderator ISPConfig Developer

    What's the output of:

    netstat -tap | grep spamd

    The output should be something like:
    tcp 0 0 localhost.localdo:spamd *:* LISTEN 12345/spamd.pid
     
    Last edited: Jun 14, 2007
  7. Xinil

    Xinil New Member

    typing: netstat -tap | grep spamd

    produces nothing as the output.
     
  8. Hans

    Hans Moderator ISPConfig Developer

    Did you setup spamassassin according "The Perfect setup" ? :confused:
     
  9. Xinil

    Xinil New Member

    Yes, I followed "The Perfect Setup - CentOS 4.4" step by step. All my services work correctly too. SpamAssassin is working fine and labels messages as spam.

    What am I missing? :(

    Also, this page: http://www.ispconfig.com/manual_installation.htm says to run the command:
    /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin

    When I run that, nothing happens, it just sits there until I hit ctrl + c. I assume that's good?
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Spamassassin is not running as daemon, there is no restart needed after you changed the local.cf file. All changes were used when the next email is scanned.
     
  11. Xinil

    Xinil New Member

    Thanks for the info, till. Is there a way to check what version I have?
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Try
    Code:
    /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin -V
     
  13. adriaan

    adriaan New Member

    ls /etc/init.d/*
    This will show all commands in that folder. You may find the application on it's name? Otherwise post the output here please.
     
  14. Xinil

    Xinil New Member

    Worked! Thanks everyone who gave a helping hand. :)
     

Share This Page