How do i check if postfix is working ?

Discussion in 'Installation/Configuration' started by showe1966, Feb 11, 2011.

  1. showe1966

    showe1966 New Member

    I am getting some errors in my mail log and so I am not sure if postfix is working.
    I did not set up my domain name etc. yet, but i would be keen to get everything working right before i transfer my production server over to my newly setup machine.
    What commands can I type from the command line to check postfix is working right ?

    NB. Errors i am getting are:
    Feb 11 00:53:08 server1 postfix/local[4674]: fatal: open database /etc/aliases.db: No such file or directory
    Feb 11 00:53:09 server1 postfix/master[2302]: warning: process /usr/lib/postfix/local pid 4674 exit status 1
    Feb 11 00:53:09 server1 postfix/master[2302]: warning: /usr/lib/postfix/local: bad command startup -- throttling
     
  2. showe1966

    showe1966 New Member

    a quick search on google reveals:-

    On a new postfix mail server installation, i got following error on console

    Jul 11 19:19:32 freebsd postfix/local[654]: fatal: open database /etc/aliases.db: No such file or directory

    The error is because postfix can't find "/etc/aliases.db". Problem is fixed with by recreating aliases.db file.

    # postfix stop
    # rm -f /etc/aliases.db
    # newaliases
    # postfix start


    This has fixed something, becuase I am getting another error now about TLS certificates...
    Onwards and upwards !!
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Which ispconfig version have you installed (name of the tar.gz file that you downloaded) and which tutorial did you use to install the server?
     
  4. showe1966

    showe1966 New Member

    Dear Till,

    My ubuntu is 10.10
    Processor type is amd 64

    Installed was

    http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz

    For install, I followed the instructions here:-

    http://www.howtoforge.com/perfect-server-ubuntu-10.10-maverick-meerkat-ispconfig-3

    The ISPCONFIG install failed twice because my mysql root password had a ' in it, causing the script to crash.

    I changed mysql root password, completed the install from where it had stopped, then removed it using the un-install command.

    Then , i installed ispconfig 3 again .

    postfix is now partially working.

    however, I am still getting some error messages relating to TLS , so I want to know some diagnostic commands I can run to see if postfix is really working or not.
    I don't have a domain name yet to assign to tmy ip address so some errors will doubtlessly occur for this reason.

    here are the error messages from the mail log:-

    Feb 11 14:59:43 server1 postfix/smtpd[31467]: cannot load Certificate Authority data: disabling TLS support
    Feb 11 14:59:43 server1 postfix/smtpd[31467]: warning: TLS library problem: 31467:error:02001002:system library:fopen:No such file or directory:bss_file.c:126:fopen('/etc/postfix/ssl/cacert.pem','r'):
    Feb 11 14:59:43 server1 postfix/smtpd[31467]: warning: TLS library problem: 31467:error:2006D080:BIO routines:BIO_new_file:no such file:bss_file.c:129:
    Feb 11 14:59:43 server1 postfix/smtpd[31467]: warning: TLS library problem: 31467:error:0B084002:x509 certificate routines:X509_load_cert_crl_file:system lib:by_file.c:274:
    Feb 11 14:59:43 server1 postfix/smtpd[31467]: connect from localhost[127.0.0.1]
    Feb 11 14:59:43 server1 postfix/smtpd[31467]: 571174858350: client=localhost[127.0.0.1]
    Feb 11 14:59:43 server1 postfix/smtpd[31467]: disconnect from localhost[127.0.0.1]
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Did you follow the tutorial to the letter?

    What's in /etc/postfix/main.cf?
     

Share This Page