How do I change the default boot

Discussion in 'Installation/Configuration' started by Sunrise, Aug 15, 2006.

  1. Sunrise

    Sunrise New Member

    I've just install the latest vertion of Fedora 5 on a new computer I just purchased. I also have windows xp installed. Linux set itself up as the default boot, which is fine by me but not the rest of the family. The last time I installed Linux it gave me a choice but not this time. How do I change this now? Also I cann't get on the net, where do I go to check and see if it as installed the right drivers

    Thanks in advance
     
  2. falko

    falko Super Moderator

  3. Sunrise

    Sunrise New Member

    Thanks for your reply, But my problem is not installing both windows and linux on the same system. I've already done that. What I would like to do is configure the grub boot loader so that it boots to windows by default and not linux. I like to use linux but the rest of the family is still stuck on windows (because of games and such) And so their grumbling about having to hover over the keyboard with only about a 3 second window in which to boot to Windows XP.
    I'm told it just a matter of editing a text file someware but I don't know where to find it.
     
  4. ManWithNoName

    ManWithNoName New Member

    I don't use Fedora, so I'm not 100% if the path is correct.
    You have to edit /boot/grub/menu.lst and change "default 0".
    If your boot menu list when you have to choose what O.S. boot up looks like:
    -Fedora
    -Fedora(save)
    -memtest
    -windowsxp
    you should have to change the value to "default 3"
     
  5. Sunrise

    Sunrise New Member

    Thanks "ManWithNoName "
    It worked like a charm
    Now I just got to find out why I can't get on the net
     
  6. ManWithNoName

    ManWithNoName New Member

    You don't specify anything about your home network:
    -ethernet or usb?
    -modem or router?
    -any DHCP server?

    What's your /sbin/ifconfig command output?

    I've installed FC5 on VMWare through ethernet and static IP config. I found 3 configuration files for networking:
    /etc/resolv.conf (DNS Server)
    /etc/sysconfig/network (GATEWAY)
    /etc/sysconfig/network-scripts/ifcfg-eth0 (IP address)
     
    Last edited: Aug 17, 2006
  7. Sunrise

    Sunrise New Member

    I have an ethernet conection using a router/firewall as my DHCP server. Never had a problem with my old systenm using core 4, it's just when I bought a new HP from Future Shop ( I'll never do that again) and installed core 5 that I had a problem. So just out of curiosty I booted a live Suse DVD to see if that would work. I didn't. So disabled the onboard ethernet and installed an old ethernet card I had lying around. Now every thing works great. So I'm assuming it was just a driver problem.
    Thanks for your help
     

Share This Page