hotmail senderID

Discussion in 'Installation/Configuration' started by terryoleary1981, Jul 29, 2008.

  1. terryoleary1981

    terryoleary1981 New Member

    hi all,

    i was having problems with the deliverability to hotmail accounts from one of my ISPConfig domains, i applied to be added to the sendersID and have had confirmation however they included this paragraph in their confirmation email and i'm not sure what it means, can anyone help?

    We reviewed your SPF record and note that it includes the "ptr" or reverse DNS lookup mechanism.  The specification for SPF records (RFC 4408) discourages use of "ptr" for performance and reliability reasons. This is especially important for Windows Live Mail, Hotmail and other large ISPs as a result of the very high volume of mail we receive each day. We highly recommend you remove the "ptr" mechanism from your SPF record and, if necessary, replace it with other SPF mechanisms that do not require a reverse DNS lookup, such as "a", "mx", "ip4" and "include." This will help ensure that Sender ID validation is performed as accurately as possible, maximizing your email deliverability while protecting your domain from spoofing.  
  2. falko

    falko Super Moderator ISPConfig Developer

    What does your SPF record look like?
  3. terryoleary1981

    terryoleary1981 New Member

    in the ispconfig dns manager for the domain my spf record just has:

    hostname <empty>

    Are emails sent from A Record?: Yes

    Are emails sent from MX Record?: Yes

    Are emails sent from all servers of this domain?: Yes

    Are emails sent from other A Records?: <blank>

    Are emails sent from other MX Records?: <blank>

    Are emails sent from other IP addresses?: <blank>

    Inherit SPF Record from this zone?: <blank>

    Do the above entries contain all hosts allowed to send emails for this domain?: Yes
  4. falko

    falko Super Moderator ISPConfig Developer

    Can you also post the output of
    dig txt
  5. terryoleary1981

    terryoleary1981 New Member

    ; <<>> DiG 9.4.2 <<>> txt
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 32396
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 2

    ; IN TXT

    ;; ANSWER SECTION: 86400 IN TXT "v=spf1 a mx ptr ~all"

    ;; AUTHORITY SECTION: 86400 IN NS 86400 IN NS

    ;; ADDITIONAL SECTION: 172800 IN A 172800 IN A

    ;; Query time: 93 msec
    ;; SERVER:
    ;; WHEN: Sat Aug 2 16:34:36 2008
    ;; MSG SIZE rcvd: 146
  6. falko

    falko Super Moderator ISPConfig Developer

    I'd disable the SPF record in ISPConfig and add the line

    Code: 86400 IN TXT "v=spf1 a mx ~all"
    (no ptr)

    manually at the end of the zone file. Restart BIND afterwards.
  7. terryoleary1981

    terryoleary1981 New Member

    next stupid questions.....where's my zone file.
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    That depends on your Linux distribution. On Debian its. e.g. in /etc/bind. Another common location is /var/lib/named
  9. terryoleary1981

    terryoleary1981 New Member

    sorry always forget to say my linux version... its Fedora 7, tried both those locations suggested to no avail.....
  10. falko

    falko Super Moderator ISPConfig Developer

    On Fedora the zone files should be somewhere in /var/named/chroot/ or /var/named/chroot/var/named.
  11. terryoleary1981

    terryoleary1981 New Member

    Thanks for that, seems to have taken the setting, still not sending to hotmail accounts but i think this takes a couple of days to take affect, e.g. for them to update their server..... i think?
  12. terryoleary1981

    terryoleary1981 New Member

    well maybe i was optimistic, still cant send to hotmail, dont have any other problem with yahoo, gmail etc.....

    I've been added to the sender id programme and removed the -prt flag from my SPF file, is there anything else i can do?

    The postmaster page doesnt seem to offer anymore advice.
  13. falko

    falko Super Moderator ISPConfig Developer

    Have you tried to contact the Hotmail support?
  14. terryoleary1981

    terryoleary1981 New Member

    I've contact hotmail support and got a reply. There are various things i can check and do to improve deliverability. one of them is checking my IP for a bad reputation. When i did this i found it to be blacklisted!

    I've looked and the host name my mail comes from is localhost.localdomain which is a postfix setting. I've sorted out my server name to using these instructions which worked.

    But need to configure my postfix correctly as it is still coming from localhost.localdomain. i;ve tried setting it in the etc/postfix main config file but with no luck.... tried to follow these

    the line i changed my main config file looks like this:

    myhostname =
    mydomain =
    In my local-host-names I have a long list of all the domain in ISPconfig with localhost, localhost.localdomain, localhost.localhost.localdomain in the top of the list, i tried commenting these out but couldnt receive any emails. FYI is in the list but not

    Any ideas?
  15. terryoleary1981

    terryoleary1981 New Member

    i found the line i needed to change it was further up..... it comes from the right domain now! So i can try and delist my ip from this blacklist

    Has anyone else had this problem before and managed to get accepted by hotmail, its quite important so i can send emails to hotmail users.

Share This Page